Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » ETSI ITS wireshark capture(Requesting ETSI ITS sample wireshark capture)
ETSI ITS wireshark capture [message #1741878] Tue, 30 August 2016 11:21 Go to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi,

I have installed wireshark version 1.12.13 on Ubuntu 64bit machine.
I have copied GN,BTP,CAM,DENM plugins(.so files) to the wireshark library folder.
But the ETSI ITS wireshark capture was not decoded by the wireshark.

The plugins are downloaded from
ht://forge.etsi.org/websvn/listing.php?repname=ITS.WIRESHARK_ITS_PLUGINS&path=%2Freleases%2Fwireshark-1.12.x%2FLinux%2F64bits%2F&#a3c1eb74feaef7c0ceaa13848dc1bd7cd

Can anybody help me out to decode the captured packet.

If anybody has ETSI ITS sample wireshark capture, please share with me. This is to cross verify that the installed plugins are working properly.

Thanks,
Anandh
Re: ETSI ITS wireshark capture [message #1741895 is a reply to message #1741878] Tue, 30 August 2016 13:52 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 760
Registered: January 2015
Senior Member
Hi Anandh,

-did you copy them to the right folder? You should see some other plug-ins there.
-did you restart wireshark?

I'll send you some files tomorrow, but I can confirm the plug-ins are working.
Maybe you can nudge it by selecting the packet and then telling wireshark to 'decode as'.


Best regards
Elemer

[Updated on: Tue, 30 August 2016 13:56]

Report message to a moderator

Re: ETSI ITS wireshark capture [message #1741907 is a reply to message #1741895] Tue, 30 August 2016 14:32 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Elemer,

Thanks for your reply.

I hope I put it in right folder (ie) /usr/local/lib/wireshark/1.12.X/.
Where I could see other plugins as well.
Afterwards I have restarted the wireshark.

Even I tried 'Decode as' option as well but in vain.

Along with your plugins, if you could provide the actual wireshark capture in which you have seen the decoded packets, that would be good.

Thanks,
Anandh
Re: ETSI ITS wireshark capture [message #1741911 is a reply to message #1741907] Tue, 30 August 2016 14:36 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 760
Registered: January 2015
Senior Member
Hi Anandh,

and it does work for other, non-ITS traffic?

BR
Elemer
Re: ETSI ITS wireshark capture [message #1741913 is a reply to message #1741911] Tue, 30 August 2016 14:40 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Yes Elemer,

You are right!!!

Regards,
Anandh
Re: ETSI ITS wireshark capture [message #1741925 is a reply to message #1741913] Tue, 30 August 2016 15:34 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 760
Registered: January 2015
Senior Member
Hi Anandh,

on a Ubuntu 14.04 my plugins are in

/usr/local/lib/wireshark/plugins/1.12.7/

 ll /usr/local/lib/wireshark/plugins/1.12.7/
total 7416
drwxr-xr-x 2 root root    4096 Oct 13  2015 ./
drwxr-xr-x 4 root root    4096 Oct 13  2015 ../
-rwxr-xr-x 1 root root   28924 Oct 13  2015 btp.so*
-rwxr-xr-x 1 root root  199312 Oct 13  2015 cam.so*
-rwxr-xr-x 1 root root  211502 Oct 13  2015 denm.so*
-rwxr-xr-x 1 root root     968 Oct 13  2015 docsis.la*
-rwxr-xr-x 1 root root  819460 Oct 13  2015 docsis.so*
-rwxr-xr-x 1 root root     980 Oct 13  2015 ethercat.la*
-rwxr-xr-x 1 root root  332675 Oct 13  2015 ethercat.so*
-rwxr-xr-x 1 root root  155007 Oct 13  2015 gn.so*
-rwxr-xr-x 1 root root     974 Oct 13  2015 gryphon.la*
-rwxr-xr-x 1 root root  197262 Oct 13  2015 gryphon.so*
-rwxr-xr-x 1 root root     956 Oct 13  2015 irda.la*
-rwxr-xr-x 1 root root  154628 Oct 13  2015 irda.so*
-rwxr-xr-x 1 root root  129636 Oct 13  2015 itsut.so*
-rwxr-xr-x 1 root root     950 Oct 13  2015 m2m.la*
-rwxr-xr-x 1 root root   59434 Oct 13  2015 m2m.so*
-rwxr-xr-x 1 root root  316861 Oct 13  2015 map.so*
-rwxr-xr-x 1 root root     956 Oct 13  2015 mate.la*
-rwxr-xr-x 1 root root  304280 Oct 13  2015 mate.so*
-rwxr-xr-x 1 root root     962 Oct 13  2015 opcua.la*
-rwxr-xr-x 1 root root  669646 Oct 13  2015 opcua.so*
-rwxr-xr-x 1 root root     980 Oct 13  2015 profinet.la*
-rwxr-xr-x 1 root root 1186683 Oct 13  2015 profinet.so*
-rwxr-xr-x 1 root root  273314 Oct 13  2015 spat.so*
-rwxr-xr-x 1 root root     992 Oct 13  2015 stats_tree.la*
-rwxr-xr-x 1 root root   34411 Oct 13  2015 stats_tree.so*
-rwxr-xr-x 1 root root     974 Oct 13  2015 unistim.la*
-rwxr-xr-x 1 root root  287217 Oct 13  2015 unistim.so*
-rwxr-xr-x 1 root root     992 Oct 13  2015 wimaxasncp.la*
-rwxr-xr-x 1 root root  186272 Oct 13  2015 wimaxasncp.so*
-rwxr-xr-x 1 root root     962 Oct 13  2015 wimax.la*
-rwxr-xr-x 1 root root     998 Oct 13  2015 wimaxmacphy.la*
-rwxr-xr-x 1 root root  198858 Oct 13  2015 wimaxmacphy.so*
-rwxr-xr-x 1 root root 1742425 Oct 13  2015 wimax.so*



So I believe yours should be
in
/usr/local/lib/wireshark/plugins/1.12.13/
and not in

/usr/local/lib/wireshark/1.12.X/

(I'm missing "plugins" and the version should be exact)

What do you think?

Re: ETSI ITS wireshark capture [message #1742069 is a reply to message #1741925] Wed, 31 August 2016 05:19 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Elemer,

There is a typo, I put it in a proper folder which you have mentioned.

In Our code there is a packet formation issue, because of which wireshark was not able to decode the packets. After fixing that, I am able to see the GN/BTP/DENM packets.

Thanks a lot for your help.

Best Regards,
Anandh

Re: ETSI ITS wireshark capture [message #1742071 is a reply to message #1742069] Wed, 31 August 2016 06:32 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 760
Registered: January 2015
Senior Member
Hi Anandh,

great , good luck then!

Best regards

Elemer
Re: ETSI ITS wireshark capture [message #1743296 is a reply to message #1742071] Wed, 14 September 2016 07:22 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Elemer,

We are testing BTP compliance through TTCN3. SUT is sending the BTP-A packet successfully to ITS(Wireshark we are able to see the packet) but ITS system did not receive any BTP packet causing the test case to inconclusive. We also verified the Java SA logs(attached) there we could not locate any GN or BTP packet processing. Kindly help me out to resolve this issue.

The test case which we ran was : TC_BTP_PGA_BV_01
Re: ETSI ITS wireshark capture [message #1743297 is a reply to message #1743296] Wed, 14 September 2016 08:06 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 13
Registered: September 2016
Junior Member
Hi Anandh,

What I can see from the logs You have provided is that the SUT is sending a malformed CAM packet instead of the expected BTP packet.

I couldn't find the BTP-A packet sent by the SUT You mentioned, or at least it is not what the testcase is expecting, this is why the testcase runs to inconclusive (it does not receive the expected message in time).

What happens in Your case is that the UppetTester initialization is successful (packets #1 and #2).

After that the TestSystem sends a utBtpTriggerA type message (packet #3), which is successfully replied by the UT (packet #4). After that instead of sending a btpNotification with a plain BTP-A header simply mirroring the received BTP-A header ("0f a0 13 88" in packet #3) the SUT sends a malformed CAM packet (packet #5). There's no sign of the simple BTP message the testcase expects.

Please check why the SUT is sending
1, malformed packet
2, CAM packet instead of BTP packet
3, A bunch of suspiciously uniform bytes in the CAM packet (empty memory regions copied into the message?)

Lenard
Re: ETSI ITS wireshark capture [message #1743454 is a reply to message #1743297] Thu, 15 September 2016 14:31 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Lenard/Elemer,

This time I tried with proper DEMN packet, still ITS is not receiving. But same time the wireshark is able to decode the packet successfully. Logs are attached. Please could you check and provide your inputs.

We are suspecting that some configuration is missing at the adapter (java jre), so its not able to receive the packet.

Best Regards,
Anandh
Re: ETSI ITS wireshark capture [message #1743510 is a reply to message #1743454] Fri, 16 September 2016 06:26 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 13
Registered: September 2016
Junior Member
Hi Anandh,

The testcase expects a simple BTP packet in response and not a CAM or DENM or any other packet.

The message flow should be the following:
(TS -> UT) 0x700FA01388 ::(0x70[SourcePort][DestinationPort])
(UT -> TS) 0x6101
(SUT -> TS) 0x010FA01388 ::(0x01[SourcePort][DestinationPort])

So the [SourcePort][DestinationPort] pair should be reflected in the mesage. In Your case the [SourcePort][DestinationPort] pair is [07D2][07D2], which does not match the original [0FA0][1388] pair, hence the message will be discarded by the TE.

Also please note that there's a known problem in the TestAdapter provided by ETSI: Please do not attach any payload to this BTP packet as it will be handled incorrectly. The correction is ready in my repo, I have to test it though, and provide it to the main repo at ETSI.

Lenard
Re: ETSI ITS wireshark capture [message #1743511 is a reply to message #1743510] Fri, 16 September 2016 06:33 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 13
Registered: September 2016
Junior Member
Anandh,

Just for the sake of clear picture: how are You involved in ITS? Are You developing an ITS station?

Thanks,
Lenard
Re: ETSI ITS wireshark capture [message #1743536 is a reply to message #1743511] Fri, 16 September 2016 09:23 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Lenard,

Thanks for quick reply.

I have changed and tried with only BTA packet with appropriate ports.But, still ITS is not receiving the same.


Please find the Adapter & Wireshark logs as an attachment.


We are developing the ITS(OBU/RSU) and planning to participate in ETSI PlugTest 2016.


Thanks
Anandha.
Re: ETSI ITS wireshark capture [message #1743690 is a reply to message #1743536] Mon, 19 September 2016 04:42 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Lenard,

Thanks for looking into it. There is an issue in ITS-TA that, it is not able to decode the unicast packet which is sent from SUT. When we send the Broadcast packet it was able to decode and execute the test case as expected.

As you mentioned before, could you send the latest TA JAR file with the fix for BTP payload issue.

Regards,
Anandh
Re: ETSI ITS wireshark capture [message #1743707 is a reply to message #1743690] Mon, 19 September 2016 07:10 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 13
Registered: September 2016
Junior Member
Hi,

Please replace Your TitanTriMapper.jar with this one.

It will not resolve the problem TA is not handling the unicast messages.

Lenard
Re: ETSI ITS wireshark capture [message #1743717 is a reply to message #1743707] Mon, 19 September 2016 08:18 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 13
Registered: September 2016
Junior Member
Hi,

Here's a package containing an even more robust TA.
Re: ETSI ITS wireshark capture [message #1743739 is a reply to message #1743717] Mon, 19 September 2016 11:15 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 13
Registered: September 2016
Junior Member
Hi Anandh,

I have checked the latest logs and the BTP message contains the same issue as I mentioned before and it should be processed by the new mapper/TA.

Is the new mapper working for You?

Lenard
Re: ETSI ITS wireshark capture [message #1743746 is a reply to message #1743707] Mon, 19 September 2016 12:33 Go to previous messageGo to next message
Anandhakumar Venkadachalam is currently offline Anandhakumar VenkadachalamFriend
Messages: 9
Registered: August 2016
Junior Member
Hi Lenard,

Thanks for sharing the latest jar file.

We are planning to run TTCN test cases defined by ETSI for ITS CMS5, which is shared on http://forge.etsi.org/websvn/listing.php?repname=ITS.ITS&path=/tags/2016-09-12-PLU5

Could you please let me know if these test cases are ported to Titan. if so can you share me the path as well.

Thanks and Regards,
Anandh
Re: ETSI ITS wireshark capture [message #1743780 is a reply to message #1743746] Mon, 19 September 2016 14:58 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 760
Registered: January 2015
Senior Member
Hi Anandh,

> Could you please let me know if these test cases are ported to Titan.

There is no straightforward answer to this; let me explain:

-Titan does not natively support PER encoding; in the solution you have we use an external open source ASN.1 compiler to generate PER encoding/decoding.
Unfortunately this compiler does not have support for Information object classes , and the version you have pointed out makes of of that. The earlier version we have used does not , so we could generate the PER encoding as described above.

So unfortunately there is no end-to-end open source solution available for newer versions of the ITS conformance stack.

However within the company we use a commercial ASN.1 compiler for PER ; if you buy the PER encoder from such a vendor, we can use it to write the PER codec functions. ETSI, and as far as we know, most TTCN-3 vendors are also using a 3rd party solution for PER codecs.

See more details here:

https://www.eclipse.org/forums/index.php/t/1070344/




Best regards

Elemer




Re: ETSI ITS wireshark capture [message #1743956 is a reply to message #1743780] Wed, 21 September 2016 07:02 Go to previous message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 760
Registered: January 2015
Senior Member
Hi Anandh,


the ITS stack repo has been moved, can be found at:


https://github.com/elnrnag/ITSG5_TS_Titanized_TA


BR Elemer


Previous Topic:Remote Build Setup
Next Topic:Type compatiblity issues in Titan
Goto Forum:
  


Current Time: Sat Jun 23 14:23:22 GMT 2018

Powered by FUDForum. Page generated in 0.02364 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top