Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » SET_POINT in FB_CTRL_PID Function Block(Can not provide data value to SET_POINT from another FB.)
SET_POINT in FB_CTRL_PID Function Block [message #1741827] Mon, 29 August 2016 22:31 Go to next message
Santosh Kumar Panda is currently offline Santosh Kumar PandaFriend
Messages: 9
Registered: June 2016
Junior Member
Hi,
Is it possible to provide an input to the SET_POINT in FB_CTRL_PID FB. I tried to provide an input data to the SET_POINT from a function block but it always has the value 0.

Thanks,
Santosh
Re: SET_POINT in FB_CTRL_PID Function Block [message #1741855 is a reply to message #1741827] Tue, 30 August 2016 08:05 Go to previous messageGo to next message
Monika Wenger is currently offline Monika WengerFriend
Messages: 17
Registered: September 2015
Junior Member
since I do not have any further information (maybe screenshot) I would guess that you never trigger the corresponding event.
Re: SET_POINT in FB_CTRL_PID Function Block [message #1741875 is a reply to message #1741855] Tue, 30 August 2016 11:12 Go to previous messageGo to next message
Santosh Kumar Panda is currently offline Santosh Kumar PandaFriend
Messages: 9
Registered: June 2016
Junior Member
Hi Monika,

PFA the screenshot of the application. Please let me know if you need any further information.

Thanks,
Santosh
Re: SET_POINT in FB_CTRL_PID Function Block [message #1741882 is a reply to message #1741875] Tue, 30 August 2016 11:43 Go to previous messageGo to next message
Monika Wenger is currently offline Monika WengerFriend
Messages: 17
Registered: September 2015
Junior Member
the SET port is only updated when an RST event is received, this is also valid for the other ports which stay 0. please always check the WITH constraints of the function block's interface.
Re: SET_POINT in FB_CTRL_PID Function Block [message #1741916 is a reply to message #1741882] Tue, 30 August 2016 14:46 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 523
Registered: January 2014
Senior Member
I think that this is a bug in the FB_CTRL_PID block. I think that SET should also be connected to the REQ event. You can do this and update your FB in your FORTE. I think that several of the inputs should also be connected to the INIT because otherwise the initialization will also not be correct. Thanks for pointing this out.
Previous Topic:Testing Wago 750-400 function block
Next Topic:Problem in communication Publish/Subscribe
Goto Forum:
  


Current Time: Sun May 20 12:24:30 GMT 2018

Powered by FUDForum. Page generated in 0.02082 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top