Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » Content-Assist for imported libraries not working
Content-Assist for imported libraries not working [message #1740289] Thu, 11 August 2016 08:46 Go to next message
Sven L. is currently offline Sven L.Friend
Messages: 16
Registered: May 2012
Junior Member
Hi,

I'm trying to get the content-assist for imported libraries to work like mentioned here: [ATL] content assist with library use

However, it does not seem to work. This is my code:

testproject/transformations/Test.atl
-- @atlcompiler emftvm
-- @nsURI EMFTVM=http://www.eclipse.org/m2m/atl/2011/EMFTVM

-- @path MM=/testproject/metamodel/MM.ecore
-- @lib Helpers=/testproject/transformations/Helpers.atl

module Test;

create OUT: MM refining IN: MM;

uses Helpers;


testproject/transformations/Helpers.atl
-- @atlcompiler emftvm
-- @nsURI EMFTVM=http://www.eclipse.org/m2m/atl/2011/EMFTVM

library Helpers;

helper def : test : String =
	'test';


If I type thisModule. in my Test module, I should be able to see the test helper, right? However, I can only see the helpers that are defined inside the same module.
The content-assist for the metamodel works fine though...

Is there something else I need to setup?
Re: Content-Assist for imported libraries not working [message #1740408 is a reply to message #1740289] Fri, 12 August 2016 15:04 Go to previous messageGo to next message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 358
Registered: September 2012
Location: Belgium
Senior Member

It still works for me...
I have had issues before with syntax completion when there's a syntax error in the ATL file you're currently editing; perhaps you can check that?


Cheers,
Dennis
Re: Content-Assist for imported libraries not working [message #1740481 is a reply to message #1740408] Sun, 14 August 2016 15:57 Go to previous messageGo to next message
Sven L. is currently offline Sven L.Friend
Messages: 16
Registered: May 2012
Junior Member
Hi Dennis, thank you for your reply.
Unfortunately this is not the case. I have compiled a simple example project, based on the Family.ecore metamodel, with one rule and one helper inside a library, and I cannot get the content assist to work.
Maybe you can try it out and see if it works for you?

https://www.dropbox.com/s/ipgp3927ykky73d/ContentAssistTest.zip?dl=0

If it works for you, maybe It helps changing to your setting.
Right now I use Eclipse Mars.2 with Eclipse Modeling Tools 4.5.2, ATL SDK 3.6.0, and ATL EMFTVM 3.7.0
(I also tried it on two different machines, in newly created workspaces)
Re: Content-Assist for imported libraries not working [message #1740512 is a reply to message #1740481] Mon, 15 August 2016 10:00 Go to previous messageGo to next message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 358
Registered: September 2012
Location: Belgium
Senior Member

You're right: content assist for imported libraries only works for helpers with context, not for thisModule... You may update the following bug for this: https://bugs.eclipse.org/bugs/show_bug.cgi?id=412272 (currently has a bad title/description).

Cheers,
Dennis
Re: Content-Assist for imported libraries not working [message #1740522 is a reply to message #1740512] Mon, 15 August 2016 11:40 Go to previous message
Sven L. is currently offline Sven L.Friend
Messages: 16
Registered: May 2012
Junior Member
Hi Dennis,
thank you for clarifying this.
However, it also does not always work for helpers with context. Sometimes I see them, sometimes I don't. I have yet to find out what causes the helper to disappear from the context menu.
I will update the bug report as soon as I investigated some more.

[Updated on: Mon, 15 August 2016 13:52]

Report message to a moderator

Previous Topic:No generate "xsi:schemaLocation" at target model
Next Topic:ATL HOT Documentation
Goto Forum:
  


Current Time: Tue May 22 14:17:42 GMT 2018

Powered by FUDForum. Page generated in 0.01543 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top