Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » Signing jars for Eclipse 3.6.x or higher(What are the correct arguments for jarsign in order to be able to install signed plugins on Eclipse 3.6 or higher)
Signing jars for Eclipse 3.6.x or higher [message #1740246] Wed, 10 August 2016 17:07 Go to next message
Gidi Gal is currently offline Gidi GalFriend
Messages: 40
Registered: July 2009
Member
Hello to the forum members,

I'm developing a plugin for an Eclipse product. It has two instances, one supports Eclipse 3.6.x and the other 4.2.x. I'm using signjar ant task to sign my plugin and feature. When I try to install it on Eclipse I keep getting "Error reading signed content" error. Doing some digging in Eclipse source and on the web I found the following links:
https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg11770.html
https://bugs.eclipse.org/bugs/show_bug.cgi?id=378155

So, I understand there's an issue with Eclipse 3.6 and signing jars with Java 1.7. I'm using IBM Java 1.6 and I still get this error.

By the way the signjar task outputs the following:
[signjar] Warning:
[signjar] Using SHA-1 digest algorithm for timestamp generation. See the -tsadigestalg option.

Any ideas how to fix this ?

Thanks,
Gidi
Re: Signing jars for Eclipse 3.6.x or higher [message #1740317 is a reply to message #1740246] Thu, 11 August 2016 14:20 Go to previous message
Gidi Gal is currently offline Gidi GalFriend
Messages: 40
Registered: July 2009
Member
An update: I found out that a work-around would be to perform the signing process with Java 1.5 and Eclipse 3.5. I'm still looking for a solution, preferably for Java 1.7.

Also, the link below describes work-around of setting the signatures on the update site instead of the jars. If anyone has a link that explains this process and whether it requires changes in workflow for the user, I'll be grateful if you could share it here.

https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg11770.html

Thanks,
Gidi

[Updated on: Thu, 11 August 2016 18:14]

Report message to a moderator

Previous Topic:How to set system environment variable eclipse configuration file?
Next Topic:P2 updating root files on Mac replaces product executable, losing executable permission
Goto Forum:
  


Current Time: Mon Nov 19 11:19:30 GMT 2018

Powered by FUDForum. Page generated in 0.01901 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top