Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » The Eclipse executable launcher was unable to locate its companion shared library.
The Eclipse executable launcher was unable to locate its companion shared library. [message #1740071] Tue, 09 August 2016 00:49 Go to next message
Billy Anon is currently offline Billy AnonFriend
Messages: 3
Registered: August 2016
Junior Member
Today I had to do a system restore for an unrelated reason. The restore point was before I installed Eclipse on this computer so I had to reinstall it. I installed it, the exact same way I did the first time and when I clicked launch, I got the error "The Eclipse executable launcher was unable to locate its companion shared library."

I have been unable to launch it all day and have tried:
Using a different JDK (tried both 7 and Cool
Reinstalling Java

And nothing seems to work.

Please, if anyone has had this problem or knows how to fix it, please let me know.

(sorry if this is in the wrong section, I couldn't find a suitable one)
Re: The Eclipse executable launcher was unable to locate its companion shared library. [message #1740072 is a reply to message #1740071] Tue, 09 August 2016 01:12 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3223
Registered: July 2009
Senior Member

You also get this message when it can't read/load the library into memory. Does your login still have ownership and/or read+execute permissions over the file tree?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: The Eclipse executable launcher was unable to locate its companion shared library. [message #1740073 is a reply to message #1740072] Tue, 09 August 2016 01:57 Go to previous messageGo to next message
Billy Anon is currently offline Billy AnonFriend
Messages: 3
Registered: August 2016
Junior Member
Sorry I'm not too sure what you mean. However, nothing of what you said sounds familiar and nothing like that has been changed as far as I'm aware.
Re: The Eclipse executable launcher was unable to locate its companion shared library. [message #1740151 is a reply to message #1740073] Tue, 09 August 2016 19:38 Go to previous messageGo to next message
Billy Anon is currently offline Billy AnonFriend
Messages: 3
Registered: August 2016
Junior Member
bump Sad
Re: The Eclipse executable launcher was unable to locate its companion shared library. [message #1740154 is a reply to message #1740151] Tue, 09 August 2016 20:27 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08/09/2016 01:38 PM, Billy Anon wrote:
> bump :(

(The way this forum works, bumping accomplishes nothing.)

Nitin asked if the user you're logging in as actually owns or has
sufficient privileges over the Eclipse filesystem artifacts?

Meanwhile, you might benefit from advice given in this sticky post at
forum's top:

https://www.eclipse.org/forums/index.php/t/198527/
Re: The Eclipse executable launcher was unable to locate its companion shared library. [message #1781563 is a reply to message #1740154] Thu, 08 February 2018 16:38 Go to previous message
Chamara Liyanage is currently offline Chamara LiyanageFriend
Messages: 1
Registered: February 2018
Junior Member
I got the same error when I tried to make a short cut to the desktop. So then I went to the Eclipse installed place on my Ubuntu 16.04 LTS machine. Then right clicked the Eclipse icon and select the " Make the Link". After that I drag and dropped that created new icon to the desktop. It's worked well.
Previous Topic:Hello everyone
Next Topic:Label Indentation / Spaces after Comment
Goto Forum:
  


Current Time: Sat Aug 18 01:17:55 GMT 2018

Powered by FUDForum. Page generated in 0.02757 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top