Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP platform build fails on fresh clone of 3.1-maintenance
RAP platform build fails on fresh clone of 3.1-maintenance [message #1739020] Tue, 26 July 2016 22:39 Go to next message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 205
Registered: February 2011
Senior Member
There is a test failure, which doesn't seem like a bad one, but nonetheless it still causes a build failure
-------------------------------------------------------------------------------
Test set: org.eclipse.rap.rwt.internal.resources.ClientResources_Test
-------------------------------------------------------------------------------
Tests run: 5, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 1.594 sec <<< FAILURE! - in org.eclipse.rap.rwt.internal.resources.ClientResources_Test
testIncludesDebugSettings(org.eclipse.rap.rwt.internal.resources.ClientResources_Test)  Time elapsed: 0.313 sec  <<< FAILURE!
java.lang.AssertionError: null
	at org.junit.Assert.fail(Assert.java:86)
	at org.junit.Assert.assertTrue(Assert.java:41)
	at org.junit.Assert.assertTrue(Assert.java:52)
	at org.eclipse.rap.rwt.internal.resources.ClientResources_Test.testIncludesDebugSettings(ClientResources_Test.java:84)

Is this just me, or is it known to fail?
I'm building on Windows 8.1 with Java 8 x64
Re: RAP platform build fails on fresh clone of 3.1-maintenance [message #1739038 is a reply to message #1739020] Wed, 27 July 2016 07:04 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2285
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
this test needs "client.js", produced by ClientBuilder. Please, run the
"org.eclipse.rap.clientbuilder", located in "releng" folder first.
Regards,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP platform build fails on fresh clone of 3.1-maintenance [message #1739164 is a reply to message #1739038] Wed, 27 July 2016 21:59 Go to previous messageGo to next message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 205
Registered: February 2011
Senior Member
The clientbuilder did run, I built the entire project with "mvn clean verify" just as it says in README.md
client.js is in org.eclipse.rap\bundles\org.eclipse.rap.rwt\target\classes and in org.eclipse.rap.rwt-3.1.0-SNAPSHOT.jar

[INFO] --- exec-maven-plugin:1.2.1:java (default) @ org.eclipse.rap.rwt ---
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt.js       204
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt\runtime\BrowserFixes.js  1336
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt\util\Arrays.js   672
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt\util\Objects.js  744
....
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt\widgets\DropDown.js      12077
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt\widgets\util\DropDownSynchronizer.js     711
*\git\org.eclipse.rap\bundles\org.eclipse.rap.rwt\js\rwt\remote\handler\DropDownHandler.js        623
Replaced 539 strings
Compressed 264 files in 849 ms
Result size: 894842 bytes

Re: RAP platform build fails on fresh clone of 3.1-maintenance [message #1739179 is a reply to message #1739164] Thu, 28 July 2016 06:59 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2285
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
.... and the test still fails?

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP platform build fails on fresh clone of 3.1-maintenance [message #1740167 is a reply to message #1739179] Wed, 10 August 2016 00:08 Go to previous messageGo to next message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 205
Registered: February 2011
Senior Member
Yes.
Re: RAP platform build fails on fresh clone of 3.1-maintenance [message #1740179 is a reply to message #1740167] Wed, 10 August 2016 07:58 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2285
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
That's strange because the RAP build is executed every night (on Linux)
with maven and it succeeded. I've also triggered the build on my machine
(Windows 7 x64 with latest Java 8 b102 x64) and all the tests passed.
Regards,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP platform build fails on fresh clone of 3.1-maintenance [message #1745165 is a reply to message #1740179] Wed, 05 October 2016 22:14 Go to previous message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 205
Registered: February 2011
Senior Member
Very strange.
I tried again on a fresh Windows 8 install with 1.8.0 u101. Same problem.
I then tried on an ARM64 Linux machine. Works perfectly.
Previous Topic:Error creating a target platform
Next Topic:a simple implementation of swipe slider
Goto Forum:
  


Current Time: Fri Aug 17 15:17:39 GMT 2018

Powered by FUDForum. Page generated in 0.02319 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top