Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Need 64 bit version of GTK+ to Run SWT App on HPUX Itanium
Need 64 bit version of GTK+ to Run SWT App on HPUX Itanium [message #1738899] Mon, 25 July 2016 19:41 Go to next message
Alex Danchenkov is currently offline Alex DanchenkovFriend
Messages: 1
Registered: July 2016
Junior Member
Hi,

We are trying to start our Java SWT application under HPUX Itanium but getting the following error:

Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
Caused by: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
/home/oracle/.swt/lib/hpux/ia64/libswt-pi-gtk-4530.so: Unable to find library 'libgtk-x11-2.0.so'.
/home/oracle/.swt/lib/hpux/ia64/libswt-pi-gtk.so: Unable to find library 'libgtk-x11-2.0.so'.
/home/oracle/.swt/lib/hpux/ia64/libswt-pi-gtk-4530.so: Unable to find library 'libgtk-x11-2.0.so'.
/home/oracle/.swt/lib/hpux/ia64/libswt-pi-gtk.so: Unable to find library 'libgtk-x11-2.0.so'.

at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.gtk.OS.<clinit>(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
at tmOraConsole.frmMain.main(frmMain.java:5297)


Actually, this library libgtk-x11-2.0.so is installed under /opt/gtk2.6/lib and included to LD_LIBRARY_PATH.
But the problem is that this library is 32 bit as confirmed by the below commands:

$ file /opt/gtk2.6/lib/libgtk-x11-2.0.so
/opt/gtk2.6/lib/libgtk-x11-2.0.so: ELF-32 shared object file - IA64

$ file /usr/local/lib/hpux32/libgtk-x11-2.0.so
/usr/local/lib/hpux32/libgtk-x11-2.0.so: ELF-32 shared object file - IA64

Where can we find 64 bit version of GTK for HPUX Itanium or build a 64 bit version? Thanks!
Re: Need 64 bit version of GTK+ to Run SWT App on HPUX Itanium [message #1739103 is a reply to message #1738899] Wed, 27 July 2016 14:24 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 772
Registered: January 2012
Senior Member

Check out the SWT FAQ for information on building.

FYI: SWT plans to drop support for HP-UX with 4.7/Oxygen in the absence of community support. If you require supporting HP-UX, you may want to approach the SWT team and devote some resources to its maintenance.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:Generate Chat for 1000 items
Next Topic:CSS styling a specific TreeItems text color
Goto Forum:
  


Current Time: Fri Sep 21 21:06:56 GMT 2018

Powered by FUDForum. Page generated in 0.01783 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top