Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP exception Could not resolve module(org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.core)
icon5.gif  RCP exception Could not resolve module [message #1738807] Mon, 25 July 2016 04:18
cho jk is currently offline cho jkFriend
Messages: 1
Registered: July 2016
Junior Member
eclipse : luna
project : jdk 1.7


[sample error]

!ENTRY org.springframework.ide.eclipse.beans.core 4 0 2016-07-25 10:20:10.441
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.core [909]
  Unresolved requirement: Import-Package: org.springframework.ide.eclipse.core
    -> Export-Package: org.springframework.ide.eclipse.core; bundle-version="3.8.0.201606301005-RELEASE"; bundle-symbolic-name="org.springframework.ide.eclipse.core"; version="0.0.0"
       org.springframework.ide.eclipse.core [930]
         Unresolved requirement: Import-Package: org.eclipse.ajdt.core; resolution:="optional"
         Unresolved requirement: Import-Package: org.eclipse.ajdt.core.javaelements; resolution:="optional"
         Unresolved requirement: Import-Package: org.eclipse.ajdt.core.model; resolution:="optional"
         Unresolved requirement: Import-Package: org.eclipse.contribution.jdt; resolution:="optional"
         Unresolved requirement: Import-Package: org.springsource.ide.eclipse.commons.core
           -> Export-Package: org.springsource.ide.eclipse.commons.core; bundle-version="3.8.0.201606300730-RELEASE"; bundle-symbolic-name="org.springsource.ide.eclipse.commons.core"; version="0.0.0"
              org.springsource.ide.eclipse.commons.core [951]
                Unresolved requirement: Require-Bundle: org.springsource.ide.eclipse.commons.frameworks.core; bundle-version="3.5.0"
                  -> Bundle-SymbolicName: org.springsource.ide.eclipse.commons.frameworks.core; bundle-version="3.8.0.201606300730-RELEASE"; singleton:="true"
                     org.springsource.ide.eclipse.commons.frameworks.core [952]
                       Unresolved requirement: Require-Bundle: org.springsource.ide.eclipse.commons.livexp
                         -> Bundle-SymbolicName: org.springsource.ide.eclipse.commons.livexp; bundle-version="3.8.0.201606300730-RELEASE"
                            org.springsource.ide.eclipse.commons.livexp [954]
                              Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


[error list]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.core [909]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.core.autowire [910]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.core.metadata [911]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.mylyn [912]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.ui [913]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.ui.editor [914]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.ui.graph [915]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.ui.livegraph [916]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.ui.refactoring [917]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.beans.ui.search [918]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.bestpractices [919]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.boot [920]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.boot.launch [921]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.boot.properties.editor [922]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.boot.properties.editor.yaml [923]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.buildship [926]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.config.core [927]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.config.graph [928]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.config.ui [929]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.core [930]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.gradle [933]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.maven [935]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.metadata [936]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.mylyn [937]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.quickfix [938]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.ui [939]
org.osgi.framework.BundleException: Could not resolve module: org.springframework.ide.eclipse.wizard [940]
org.osgi.framework.BundleException: Could not resolve module: org.springsource.ide.eclipse.commons.configurator [949]
org.osgi.framework.BundleException: Could not resolve module: org.springsource.ide.eclipse.commons.content.core [950]
org.osgi.framework.BundleException: Could not resolve module: org.springsource.ide.eclipse.commons.core [951]
org.osgi.framework.BundleException: Could not resolve module: org.springsource.ide.eclipse.commons.frameworks.core [952]
org.osgi.framework.BundleException: Could not resolve module: org.springsource.ide.eclipse.commons.frameworks.ui [953]


[My eclipse]
I think the problem seems to spring ide plugin is applied to the 3.8 version.

[Sample eclipse]
I have other configuration.
sample eclipse environment (spring ide 3.7 is applied)
It has been applied to a normal operation.

<Specific details>
The workspace of the [sample eclipse]
[My eclipse] behaves during normal import into the environment.


The goal of the migration project [sample ecilpse] to mars


How To resolve the above error ...
Previous Topic:Using local web content for Help System
Next Topic:Use multiple Eclipse Activities on the same UI element
Goto Forum:
  


Current Time: Fri Nov 16 09:14:20 GMT 2018

Powered by FUDForum. Page generated in 0.02641 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top