Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Xdebug cannot remote debug (Happens after upgrade to Windows 19)
icon5.gif  Xdebug cannot remote debug [message #1738493] Wed, 20 July 2016 10:42 Go to next message
Ethereal1m Mising name is currently offline Ethereal1m Mising nameFriend
Messages: 37
Registered: January 2010
Member
Dear all,
After upgrade to windows 10, I'm unable to connect to remote host. The log says:
I: Checking remote connect back address.
I: Remote address found, connecting to ::1:9001.
E: Could not connect to client. :-(


The following is xdebug configuration:
xdebug.remote_enable = true
xdebug.remote_handler=dbgp
xdebug.remote_connect_back = 1
xdebug.remote_host=localhost
xdebug.remote_port=9001
xdebug.idekey=netbeans-xdebug
xdebug.remote_log="D:/wamp/tmp/xdebug.log"
output_buffering=off
xdebug.profiler_enable = 0


I didn't forget to set Debugger port to 9001 in the Eclipse options.

What did I miss?
regards
Re: Xdebug cannot remote debug [message #1738494 is a reply to message #1738493] Wed, 20 July 2016 10:46 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 207
Registered: March 2013
Senior Member
Your problem looks similar to this: http://stackoverflow.com/questions/11563280/php-remote-debugging-xdebug-cant-connect-to-jetbrains-php-storm-client

Your localhost is resolved to ipv6 ::1, rather than ipv4 127.0.0.1.


Re: Xdebug cannot remote debug [message #1738572 is a reply to message #1738494] Thu, 21 July 2016 02:59 Go to previous messageGo to next message
Ethereal1m Mising name is currently offline Ethereal1m Mising nameFriend
Messages: 37
Registered: January 2010
Member
Great this solves the problem! thanks. I had this 2 conflicting config:

xdebug.remote_connect_back = 1
xdebug.remote_host=localhost

Regards
Re: Xdebug cannot remote debug [message #1739052 is a reply to message #1738572] Wed, 27 July 2016 09:06 Go to previous messageGo to next message
nicolas Bunnet is currently offline nicolas BunnetFriend
Messages: 7
Registered: April 2016
Junior Member
Hello,
great thanks for sharing ... solved many problems .. and i really hate that windows 10 :/
http://www.2upimg.com/img/1468576192.jpg
Re: Xdebug cannot remote debug [message #1739187 is a reply to message #1739052] Thu, 28 July 2016 08:15 Go to previous message
katie swift is currently offline katie swiftFriend
Messages: 5
Registered: July 2016
Junior Member
i still use window 7 and i find it ok. i find window 10 not simple as my os. iat first i am quite confused to use it. However, i also want to try window 10 more. thanks for sharing. i will consider this solution to problem when i upgrade.

[Updated on: Thu, 28 July 2016 08:17]

Report message to a moderator

Previous Topic:[Feature] Code-assist : Get class name as string
Next Topic:CFEclipse, how to connect to coldfusion server using RDS ?
Goto Forum:
  


Current Time: Wed Jan 24 12:02:06 GMT 2018

Powered by FUDForum. Page generated in 0.01525 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software