Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » How to update org.eclipse.help.base and help.webapp plugins(Updating Plugin code)
How to update org.eclipse.help.base and help.webapp plugins [message #1738418] Tue, 19 July 2016 15:41
Dan Connell is currently offline Dan ConnellFriend
Messages: 5
Registered: October 2013
Junior Member
I have added some code to fix a bug found in the org.eclipse.help.base and org.eclipse.help.webapp plugins for Eclipse 3.7.0. I created an update site and have been building a feature that updates both the org.eclipse.help.base and help.webapp plugins. I try to install this via the Install Software mechanism, but I get the following errors:

Cannot complete the install because of a conflicting dependency.
Software being installed: Feature 1.0.1.201607111453 (org.eclipse.help.webapp.feature.feature.group 1.0.1.201607111453)
Software currently installed: Eclipse SDK 3.7.0.I20110613-1736 (org.eclipse.sdk.ide 3.7.0.I20110613-1736)
Only one of the following can be installed at once:
Help System Base 3.6.3.201607111453 (org.eclipse.help.base 3.6.3.201607111453)
Help System Base 3.6.2.v201202080800 (org.eclipse.help.base 3.6.2.v201202080800)
Help System Base 3.6.0.v201106131736 (org.eclipse.help.base 3.6.0.v201106131736)
Cannot satisfy dependency:
From: Eclipse Help System 1.3.0.v20110327-7i7uFFiFFt6ZqnbOrMXLd1 (org.eclipse.help.feature.group 1.3.0.v20110327-7i7uFFiFFt6ZqnbOrMXLd1)
To: org.eclipse.help.base [3.6.0.v201106131736]
Cannot satisfy dependency:
From: Feature 1.0.1.201607111453 (org.eclipse.help.webapp.feature.feature.group 1.0.1.201607111453)
To: org.eclipse.help.base [3.6.3.201607111453]
Cannot satisfy dependency:
From: Eclipse Project SDK 3.7.0.v20110426-7Q7xA7DPb31rE2_TcfD-VPkLqq8sfDmLus7XtaSo-7NHB (org.eclipse.sdk.feature.group 3.7.0.v20110426-7Q7xA7DPb31rE2_TcfD-VPkLqq8sfDmLus7XtaSo-7NHB)
To: org.eclipse.help.feature.group [1.3.0.v20110327-7i7uFFiFFt6ZqnbOrMXLd1]
Cannot satisfy dependency:
From: Eclipse SDK 3.7.0.I20110613-1736 (org.eclipse.sdk.ide 3.7.0.I20110613-1736)
To: org.eclipse.sdk.feature.group [3.7.0.v20110426-7Q7xA7DPb31rE2_TcfD-VPkLqq8sfDmLus7XtaSo-7NHB]

What do I need to do to load these two new plugins and replace the ones I have ? Thanks !
Previous Topic:Avoid stacktrace in ErrorLog-Details Window
Next Topic:Error occurred during: "Initializing plug-in models"
Goto Forum:
  


Current Time: Wed Sep 19 19:01:22 GMT 2018

Powered by FUDForum. Page generated in 0.01526 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top