Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Setting SSH connection on secondary ethernet card(RSE SSH Connection)
Setting SSH connection on secondary ethernet card [message #1738191] Mon, 18 July 2016 02:05 Go to next message
Daniel Wear is currently offline Daniel WearFriend
Messages: 2
Registered: July 2016
Junior Member
I've been working on setting up a development PC to do some programming on an FPGA development board (Red Pitaya).
Using VirtualBox on a Windows 7 PC
Running Ubuntu 14.04
Installed Eclipse Neon

When setting up the remote system explorer, I can create a new connection but I am unable to get to the last screen where I select the option to add ssh.Terminals (as referenced in a guide I am working from wiki.redpitaya.com/index.php?title=Eclipse_for_Linux.

I dug into this a little bit, and there are some resources on google saying that the newer releases of Eclipse no longer come packaged with the ssh.Terminal for RSE. I installed it from the following link: http://download.eclipse.org/tm/terminal/updates/4.0/. However, this still did not allow me to access the last screen and "enable" the ssh.Terminal.

I did find that you can right click on the new Linux connection you have created and select "Open a Terminal".

I am greeted with the error message:
Error connecting 192.168.1.100 : SSH client error: connection is closed by foreign host

From the Ubuntu desktop, I can access a terminal window and log on just fine using:
ssh root@192.168.1.100

*/ Update /* I have tried launching the shell from Eclipse by right clicking "Local Shells" and selecting "Launch Shell". I can then connect to the development board by typing: ssh UserName@IPAddress. I'm not familiar with Eclipse or how to use the "Remote Debugging" feature, just wondering if this method will allow me to do so, otherwise, I am still unsure how to get the ssh.Terminal to work.

One thing to note about this system, I have two ethernet cards. I am behind a corporate firewall, and the only way I could find to get the Red Pitaya to connect via ethernet to my system was to have a second ethernet card installed. The first card access the internet as well as the corporate LAN. The second is directly wired into the FPGA development board.

Has anyone experienced these issues with RSE?
1) Anyone know if accessing the terminal window by right clicking and selecting "Open Terminal..." is the correct way to do this?
2) If not, does anyone know how to get the ssh.Terminal screen back into the RSE setup?
3) Could Eclipse be confused on my ethernet connections and be trying to only access the Red Pitaya on eth0 (ethernet card connected to the corporate LAN) as opposed to eth2 (ethernet card connected to the Red Pitaya)?

[Updated on: Mon, 18 July 2016 12:15]

Report message to a moderator

Re: Setting SSH connection on secondary ethernet card [message #1738420 is a reply to message #1738191] Tue, 19 July 2016 15:50 Go to previous message
Daniel Wear is currently offline Daniel WearFriend
Messages: 2
Registered: July 2016
Junior Member
*/ Solved /*

Finally found this thread which the solution is discussed:

https://www.eclipse.org/forums/index.php/t/154117/
Previous Topic:Eclipse won't start
Next Topic:how to debug existing plugin
Goto Forum:
  


Current Time: Tue Sep 24 09:32:08 GMT 2019

Powered by FUDForum. Page generated in 0.03505 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top