Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » PermGen space problem eclipse kepler(PermGen space problem eclipse kepler)
PermGen space problem eclipse kepler [message #1736335] Tue, 28 June 2016 13:22 Go to next message
sanket jani is currently offline sanket janiFriend
Messages: 2
Registered: June 2016
Junior Member
Hello everyone

i am having problem with eclipse kepler .

when i try to install groovy from the eclipse market place it is showing the permgen space error and there after it stop working , need to restart it .

i am using windows 8 and jdk 1.6 64-bit .

i am attaching my screenshot with this.

thank you .
  • Attachment: permgen.png
    (Size: 104.65KB, Downloaded 70 times)
Re: PermGen space problem eclipse kepler [message #1736346 is a reply to message #1736335] Tue, 28 June 2016 16:02 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30208
Registered: July 2009
Senior Member
Easiest would be to install a 1.8 JDK. Failing that, edit the
eclipse.ini to increase the permgen value.

https://wiki.eclipse.org/FAQ_How_do_I_increase_the_permgen_size_available_to_Eclipse%3F


On 28.06.2016 11:15, sanket jani wrote:
> Hello everyone
>
> i am having problem with eclipse kepler .
>
> when i try to install groovy from the eclipse market place it is showing the permgen space error and there after it stop working , need to restart it .
>
> i am using windows 8 and jdk 1.6 64-bit .
>
> i am attaching my screenshot with this.
>
> thank you .
Re: PermGen space problem eclipse kepler [message #1736363 is a reply to message #1736346] Tue, 28 June 2016 20:44 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3416
Registered: July 2009
Senior Member

For that matter, move up to Neon as well. Kepler's original release is now 3 years old.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: PermGen space problem eclipse kepler [message #1736383 is a reply to message #1736363] Wed, 29 June 2016 05:44 Go to previous messageGo to next message
sanket jani is currently offline sanket janiFriend
Messages: 2
Registered: June 2016
Junior Member
thanks for reply to all ,
but the problem is that i haven't admin rights to change the jdk version .
i have to use this version only.
and problem is still there
Re: PermGen space problem eclipse kepler [message #1736435 is a reply to message #1736383] Wed, 29 June 2016 12:08 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30208
Registered: July 2009
Senior Member
Then you should speak to your admin. You can also pass arguments on the
command line (or on Windows from a link) for both these things.


On 29.06.2016 01:44, sanket jani wrote:
> thanks for reply to all ,
> but the problem is that i haven't admin rights to change the jdk
> version .
> i have to use this version only.
> and problem is still there
Previous Topic:Mars 2 rc3 links not working
Next Topic:xtext grammar remove validation?
Goto Forum:
  


Current Time: Wed Jun 19 15:20:18 GMT 2019

Powered by FUDForum. Page generated in 0.03428 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top