Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Create GMF Project, Acceleo plugins or Stand Alone
Create GMF Project, Acceleo plugins or Stand Alone [message #1735420] Sun, 19 June 2016 03:40
Cristina Magaña is currently offline Cristina MagañaFriend
Messages: 1
Registered: June 2016
Junior Member
I have several problems..

I created a Ecore Metamodel for a tool that creates code PHP, MySQL and HTML, based on model to text transformation, using GMF and Acceleo for the graphical editor and the M2T.
I alredy have all working fine. In my workspace i have my .diagram, .edit, .test, all the models, the graph, tooling, maping, etc. And I run my .diagram as a Eclipse aplication (runtime). and there I have my acceleo project and my acceleo UI project. Ones I model a "websitie" i run the .mlt of the acceleo to generate the code.
To this point ALL works fine.

Now, I created a plugin for each folder (or project) that I have... by using the wizzard (ritgh clic->export->Depleyable plug-ins and fragments. directory /.../eclipse/dropins), the ones on the the workspace. the acceleo and UI(in the runtime or even in the same workspace)

After that, I re-start the eclipse... and now i can create a model in the workspace and in the runtime prefecly fine.....

I delete ALL from the workspace and the runtime and try to use the ui in the workspace (mymodel->rigth clic-> Acceleo Model to Text->Generate "Sample") and it does not work....

I now why it is not working..... it is beacuse, in order to make the UI works, the Acceleo project needs to be in the place it was created.... BUT I DONT WANT ANYTHING of Ecore Metamodel, GMF project or Acceleo project neither in the workspace or in the runtime...

So... there is any solution????

Now, when i leave the Acceleo project and try to do the transformation i ONLY can do it in the runtime

In this case I also know why.... and here is my second problem

When firts create my new model, this is the code that i find.........


<?xml version="1.0" encoding="UTF-8"?>
<form_ecore:Website xmi:version="2.0" xmlns:xmi="http:// www.omg.org/XMI" xmlns:form_ecore="http:// www.example.org/form_ecore"/>


BUT in order to do the work, it needs to start with this..........


<?xml version="1.0" encoding="UTF-8"?>
<form_ecore:Website xmi:version="2.0" xmlns:xmi="http:// www.omg.org/XMI" xmlns:xsi="' http:// www.w3.org/2001/XMLSchema-instance"
    xmlns:form_ecore="http:// www.example.org/form_ecore" xsi:schemaLocation="http:// www.example.org/form_ecore form_ecore.ecore"/>


How can i make this changes????

OR there is ANYTHING i can do to make my tool (ecore model, GMF, acceleo) works as a stand alone?
well I know a stand alone it means to be outside eclipse.... maybe it is not what I am looking for....

If it helps i want to create something kind of like webratio....

I really sorry for my grammar but at this point I REALLY dont know what to do....
Previous Topic:cant open eclipse mars
Next Topic:Eclipse marketplace unavailable on Mars
Goto Forum:
  


Current Time: Tue Sep 24 09:15:59 GMT 2019

Powered by FUDForum. Page generated in 0.03029 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top