Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Problem during product configuration(Problem during product configuration)
icon5.gif  Problem during product configuration [message #1734621] Fri, 10 June 2016 04:52
naveen ramesh is currently offline naveen rameshFriend
Messages: 56
Registered: May 2016
Member
Hi,
Requirements using:Eclipse Mars(4.5.2) and Jdk(1.8.0)

Problem: I have created the plug-in-project called [org.basicfamily.sirius.design].
Then the product configuration was created for the plug-in [org.basicfamily.product.demonstrator] and the plug-in project [org.basicfamily.sirius.design] was added as contents to the created product configuration and selected the required dependencies for the plug-in [org.basicfamily.sirius.design] . Now the plug-in [[b]org.basicfamily.sirius.design[/b is dependent on the another plug in called [org.antlr.runtime[1.6.0,1.7.0)]. But the problem now is when i try to export the product it is giving [org.antlr.runtime[1.6.0,1.7.0)] bundle version exception plug in org.antlr.runtime[1.6.0] is not found.Because in the contents of the product configuration we can add the plug-in only with respect to name and not with respect to versions.So i want to add the plug-ins org.antlr.runtime[1.6.0],org.antlr.runtime[1.7.0] both but it allows only one plug-in with the same name.It will consider the plugins only with respect to the name and not w.r.t the versions.

Any solution for this problem?

[Updated on: Fri, 17 June 2016 04:12]

Report message to a moderator

Previous Topic:How to implement Quick Fix / Quick Assist for custom editor?
Next Topic:Reload Eclipse Editor
Goto Forum:
  


Current Time: Fri Sep 21 13:21:55 GMT 2018

Powered by FUDForum. Page generated in 0.01656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top