Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » EclipseLink: static weaving, inheritance and OSGi
EclipseLink: static weaving, inheritance and OSGi [message #1734509] Thu, 09 June 2016 05:05
Pavel No is currently offline Pavel NoFriend
Messages: 45
Registered: May 2016
Member
Although this question is not directly related to gemini, it is related with osgi and eclipselink that why I decided to ask it here.

I use eclipselink 2.6.3. And I have two classes:
@Entity
class ClassA extends ClassB{...}

@MappedSuperclass
class ClassB{...}

And I do static weaving using maven-plugin:
           <plugin>
               <groupId>de.empulse.eclipselink</groupId>
               <artifactId>staticweave-maven-plugin</artifactId>
               <version>1.0.0</version>
               <executions>
                   <execution>
                       <phase>process-classes</phase>
                       <goals>
                           <goal>weave</goal>
                       </goals>
                       <configuration>
                           <persistenceXMLLocation>META-INF/persistence.xml</persistenceXMLLocation>
                           <logLevel>ALL</logLevel>
                       </configuration>
                   </execution>
               </executions>
               <dependencies>
                   <dependency>
                       <groupId>org.eclipse.persistence</groupId>
                       <artifactId>org.eclipse.persistence.jpa</artifactId>
                       <version>${eclipselink.version}</version>
                   </dependency>
               </dependencies>
           </plugin>

When ClassA and ClassB are in the same bundle weaving works. However, when they are in different bundles weaving doesn't work (although I added this plugin to both bundles). How to fix this problem?
Previous Topic:JPA: EntityGraph -> FetchGroupException when Entity is in another bundle
Next Topic:Does Gemini work with EclipseLink 2.7.0?
Goto Forum:
  


Current Time: Thu Sep 20 11:09:05 GMT 2018

Powered by FUDForum. Page generated in 0.01528 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top