Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Problem exporting standalone GMF editor
Problem exporting standalone GMF editor [message #1733679] Tue, 31 May 2016 00:22 Go to next message
Konstantinos Angelopoulos is currently offline Konstantinos AngelopoulosFriend
Messages: 3
Registered: November 2015
Junior Member
Hi everyone,

I have to tell you that I am a noob at eclipse RCP and GMF and after a lot of effort I managed to make my editor and make an RCP out of it. First of all, it runs perfectly well if I execute it as an eclipse application. However, I want to create an executable eclipse product out of it. I created the .product file in the .diagram generated folder and I try to run it. However, I get the following error when I try to open the generated application:

!SESSION 2016-05-31 01:07:48.656 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_92
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -clearPersistedState
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -clearPersistedState

!ENTRY org.eclipse.osgi 4 0 2016-05-31 01:07:53.239
!MESSAGE Application error
!STACK 1
java.lang.NoClassDefFoundError: org/eclipse/jface/databinding/swt/DisplayRealm
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:606)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at JTrustName.diagram.application.JTrustApplication.start(JTrustApplication.java:19)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
at org.eclipse.equinox.launcher.Main.run(Main.java:1515)
Caused by: java.lang.ClassNotFoundException: org.eclipse.jface.databinding.swt.DisplayRealm cannot be found by org.eclipse.ui.workbench_3.107.1.v20160120-2131
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:439)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:352)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:344)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 15 more


Do you have any clue what's wrong?
Re: Problem exporting standalone GMF editor [message #1734863 is a reply to message #1733679] Mon, 13 June 2016 14:51 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 431
Registered: July 2009
Senior Member

Hi,

You did not include the databinding bundle in your product or one of its dependencies. In the product editor on the contents tab try "Add required".

Cheers,

Wim
Re: Problem exporting standalone GMF editor [message #1734878 is a reply to message #1733679] Mon, 13 June 2016 14:51 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 423
Registered: July 2009
Senior Member
Hi,

You did not include the databinding bundle in your product or one of its dependencies. In the product editor on the contents tab try "Add required".

Cheers,

Wim
Re: Problem exporting standalone GMF editor [message #1736114 is a reply to message #1734878] Sun, 26 June 2016 16:49 Go to previous message
Konstantinos Angelopoulos is currently offline Konstantinos AngelopoulosFriend
Messages: 3
Registered: November 2015
Junior Member
Hi,

I have it there, but still it's not working.
I checked the content in the product file, the run configuration and the dependencies of the plugin. It's present... but it's not working. Any ideas?

Cheers,

Konstantinos
Previous Topic:How to access Icons under src/main/resources folder in Mars.2
Next Topic:Application - Product - Feature
Goto Forum:
  


Current Time: Thu Sep 20 12:13:51 GMT 2018

Powered by FUDForum. Page generated in 0.01950 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top