Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error
icon9.gif  Error [message #1733512] Sun, 29 May 2016 09:16 Go to next message
Roberto Valentino is currently offline Roberto ValentinoFriend
Messages: 4
Registered: May 2016
Junior Member
When I create a new java project,I can't run it because it say me:

Build path specifies execution environment OSGi/Minimum-1.2. There are no JREs installed in the workspace that are strictly compatible with this environment.


Could someone help me?
Re: Error [message #1733637 is a reply to message #1733512] Mon, 30 May 2016 14:44 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30230
Registered: July 2009
Senior Member
Roberto,

What's there in Window -> Preferences -> Java -> Installed JREs? I'd
expect there's normally a default one, but failing that, you can add one
and point it a JDK you have on your machine.


On 30.05.2016 06:29, Roberto Valentino wrote:
> When I create a new java project,I can't run it because it say me:
>
> Build path specifies execution environment OSGi/Minimum-1.2. There are
> no JREs installed in the workspace that are strictly compatible with
> this environment.
>
> Could someone help me?
Re: Error [message #1733642 is a reply to message #1733637] Mon, 30 May 2016 15:41 Go to previous messageGo to next message
Roberto Valentino is currently offline Roberto ValentinoFriend
Messages: 4
Registered: May 2016
Junior Member
I have jre1.8.0 _91 selected.
Re: Error [message #1733648 is a reply to message #1733642] Mon, 30 May 2016 16:51 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30230
Registered: July 2009
Senior Member
So then it's a question of what you've specified in the launch
confirmation. I.e., in Run -> Run Configurations... probably under
Java Applications is your launch configuration. There's a JRE tab for
it. In the worst case, you should be able to select Alternate JRE to
pick this 1.8 JRE you apparently have available.


On 30.05.2016 17:41, Roberto Valentino wrote:
> I have jre1.8.0 _91 selected.
Re: Error [message #1733650 is a reply to message #1733648] Mon, 30 May 2016 17:10 Go to previous messageGo to next message
Roberto Valentino is currently offline Roberto ValentinoFriend
Messages: 4
Registered: May 2016
Junior Member
I haven't a launch configuration Confused
Then I have to create one?

Re: Error [message #1733661 is a reply to message #1733650] Mon, 30 May 2016 18:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30230
Registered: July 2009
Senior Member
Roberto,

Oh yes, you said it's just a problem building. Sorry.

In Java -> Compiler -> Building there is a preference "No strictly
complatible JRE for execution environment available" with is probably
set to error for your, where you can set it to ignore. I wonder, what
is your setting for Java -> Compiler JDK Compliance?


On 30.05.2016 19:10, Roberto Valentino wrote:
> I haven't a launch configuration :? Then I have to create one?
>
Re: Error [message #1733755 is a reply to message #1733661] Tue, 31 May 2016 12:57 Go to previous message
Roberto Valentino is currently offline Roberto ValentinoFriend
Messages: 4
Registered: May 2016
Junior Member
Thank you very much!
I set the preference "No strictly complatible JRE for execution environment available" to ignore and now It's work! Surprised
Previous Topic:\Contents\MacOS does not exist. in eclipse 4.5.2
Next Topic:selective project creation from existing tree
Goto Forum:
  


Current Time: Wed Jun 26 15:09:58 GMT 2019

Powered by FUDForum. Page generated in 0.02999 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top