Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » OSGI fragment bundle not connected to websockets deployed in Virgo nano(OSGI fragment bundle not connected to websockets deployed in Virgo nano)
OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731325] Wed, 04 May 2016 09:57 Go to next message
Chandre Gowda is currently offline Chandre GowdaFriend
Messages: 56
Registered: April 2013
Member
Hello,

I have OSGI bundles deployed in Virgo nano server(3.6.4). i am suppose to deploy websocket endpoint in OSGI bundle and web client will connect to this websocket endpoint. If we deploy websocket class in host bundle and if it has 'Web-ContextPath: appserver', then following url will connect from client to server(websocket connection).

ws://localhost/appserver/consolelogs

However if we deploy websocket class in fragment bundle which is attached to the above host bundle, the same above websocket url doesn't work. Could any of you let us know what is missing here ?

Thanks
Chandru
Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731326 is a reply to message #1731325] Wed, 04 May 2016 10:02 Go to previous messageGo to next message
GianMaria Romanato is currently offline GianMaria RomanatoFriend
Messages: 49
Registered: November 2015
Member
Hi

did you check that the fragment is properly resolved and attached to the host?

You can see that from the OSGi console or the Web console by looking at the status of the host. You should see there whether the fragment is attached.

GianMaria.
Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731337 is a reply to message #1731326] Wed, 04 May 2016 12:12 Go to previous messageGo to next message
Chandre Gowda is currently offline Chandre GowdaFriend
Messages: 56
Registered: April 2013
Member
Thanks for the reply. Yes, the fragment is attached to host bundle and resolved. Iam not sure why the link is still not working.

[Updated on: Wed, 04 May 2016 12:14]

Report message to a moderator

Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731343 is a reply to message #1731337] Wed, 04 May 2016 13:02 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 276
Registered: October 2010
Senior Member
Hi,

Check this [1]. It may appear that you face this issue.

Regards,
Violeta

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=395141
Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731346 is a reply to message #1731343] Wed, 04 May 2016 13:25 Go to previous messageGo to next message
Chandre Gowda is currently offline Chandre GowdaFriend
Messages: 56
Registered: April 2013
Member
Iam not sure about that because other fragmented bundles have spring annotations like @Controller, @Autowired etc are working properly. Only Fragment bundles which have websocket annotations like @ServerEndpoint are not working.
Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731347 is a reply to message #1731346] Wed, 04 May 2016 13:28 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 276
Registered: October 2010
Senior Member
Gemini Web (OSGi Web Container) does not process spring annotations, only those specified in Servlet and Websocket specifications. @ServerEndpoint is such annotation.
Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1731458 is a reply to message #1731347] Thu, 05 May 2016 13:25 Go to previous messageGo to next message
Chandre Gowda is currently offline Chandre GowdaFriend
Messages: 56
Registered: April 2013
Member
Iam sorry, i couldn't get it. Currently the Fragment bundle supports spring annotations but not websocket annotations. Is it a limitation ?
Re: OSGI fragment bundle not connected to websockets deployed in Virgo nano [message #1732048 is a reply to message #1731458] Thu, 12 May 2016 08:35 Go to previous message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 276
Registered: October 2010
Senior Member
yes
Previous Topic:HttpService and ServiceTracker
Next Topic:Classes not being found
Goto Forum:
  


Current Time: Mon Nov 12 17:32:40 GMT 2018

Powered by FUDForum. Page generated in 0.02211 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top