Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Welcome screen blank (Ubuntu 16.04)
Eclipse Welcome screen blank (Ubuntu 16.04) [message #1731300] Wed, 04 May 2016 08:03 Go to next message
Joakim Vrangum is currently offline Joakim VrangumFriend
Messages: 2
Registered: May 2016
Junior Member
Hi everyone,

I've had a few issues installing Eclipse Mars.2 Release (4.5.2 - Build id: 20160218-0600). I installed it in the /opt/ folder on my Ubuntu 16.04 fresh installation, as I would prefer to have it visible for different users and not glued to my /home/ directory. After some tweaking I now have the program loading without any errors, but the only problem I've yet to solve is this;

The welcome screen is blank. Does anyone know what could be causing this, and how to fix it? I'm guessing the welcome screen is made using some sort of webkit plugin, and that there is some issue with this and possibly some installed package in Ubuntu.

Please note that I am fairly new to Linux, and this is my first ever attempt at learning Eclipse (and Java) so please take that into consideration. Any help is greatly appreciated.

Best regards,
Joakim
Re: Eclipse Welcome screen blank (Ubuntu 16.04) [message #1731422 is a reply to message #1731300] Thu, 05 May 2016 06:45 Go to previous messageGo to next message
Diamantis Karagkiaouris is currently offline Diamantis KaragkiaourisFriend
Messages: 8
Registered: March 2016
Junior Member
As far as i am aware this is an issue with GTK 2 and GTK 3. You can force eclipse to use one of them and not both of them on demand as it is by default. I use Debian XFCE and i fix it by running eclipse with this parameter:

--launcher.GTK_version 2 (in eclipse.ini or on eclipse binary)

or

export SWT_GTK3=0 (on bash shell)

I hope it helps!
Re: Eclipse Welcome screen blank (Ubuntu 16.04) [message #1731468 is a reply to message #1731422] Thu, 05 May 2016 16:27 Go to previous messageGo to next message
Joakim Vrangum is currently offline Joakim VrangumFriend
Messages: 2
Registered: May 2016
Junior Member
Thank you very much! That actually did the trick. Not only that; it fixed a lot of other issues as well with windows freezing, or buttons not responding when clicked. I can finally start using the program now Wink

Best regards,
Joakim
Re: Eclipse Welcome screen blank (Ubuntu 16.04) [message #1744991 is a reply to message #1731468] Mon, 03 October 2016 20:52 Go to previous message
Brett Holcomb is currently offline Brett HolcombFriend
Messages: 9
Registered: July 2016
Junior Member
I'm runnning 4.6.0, build id: 20160613-1800 and have the same issue. I've tried the --launcher.GTK_version set to 2 and then 3 with no luck. Any other ideas. I get the welcome tab but it's blank and there are no entries in the log file other than can't open port 9000, 20080, and 10137. I'm not using the debugger yet so I can ignore these.

[Updated on: Mon, 03 October 2016 22:08]

Report message to a moderator

Previous Topic:Cannot remove an explorer hierarchy attached to top of main editor window
Next Topic:NEON JEE - Content assist for EL expression
Goto Forum:
  


Current Time: Mon Jun 24 13:31:23 GMT 2019

Powered by FUDForum. Page generated in 0.02804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top