Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Eclipse Plugin Install Error(Eclipse Plugin Install Error)
Eclipse Plugin Install Error [message #1731273] Wed, 04 May 2016 06:26 Go to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
Hi Christian,

I have created plugin for my dsl editor that developed using xtext.

It is installing on my eclipse IDE successfully but when I using the same plugin on some other system it is throwing below error. I debug the plugin but I didn't get the solution.

index.php/fa/25806/0/

I checked in my plugin it contains all the artifacts like :



Please find the attached plugin. Could you please tell me the bug in my setup?

[Updated on: Wed, 04 May 2016 09:35]

Report message to a moderator

Re: Eclipse Plugin Install Error [message #1731275 is a reply to message #1731273] Wed, 04 May 2016 06:46 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
the screenhot is irrelevant. the interesting point is what is in the error message. it says you what is wrong.

in the screenshot you can only see the beginning of the message: requires bundle ...


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Eclipse Plugin Install Error [message #1731280 is a reply to message #1731275] Wed, 04 May 2016 06:56 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
The error message is

Cannot complete the install because one or more required items could not be found.
Software being installed: JPL_Plugin_Editor 1.0.0.201605032306 (JPL_Plugin_Editor.feature.group 1.0.0.201605032306)
Missing requirement: com.prolifics.jpl.JPLEditor.tests 1.0.0.201605032306 (com.prolifics.jpl.JPLEditor.tests 1.0.0.201605032306) requires 'bundle org.eclipse.xtext.junit4 0.0.0' but it could not be found
Cannot satisfy dependency:
From: JPL_Plugin_Editor 1.0.0.201605032306 (JPL_Plugin_Editor.feature.group 1.0.0.201605032306)
To: com.prolifics.jpl.JPLEditor.tests [1.0.0.201605032306]
Re: Eclipse Plugin Install Error [message #1731282 is a reply to message #1731280] Wed, 04 May 2016 06:58 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
are you sure you want to add the tests to your feature? i would not have added them to the feature

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Eclipse Plugin Install Error [message #1731284 is a reply to message #1731282] Wed, 04 May 2016 07:12 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
Hi Christian,

I am new to xtext. This is the first time I am working on it. So I don't know what all are required to create a plugin so at the time of plugin creation I have added all the artifacts.

Re: Eclipse Plugin Install Error [message #1731286 is a reply to message #1731284] Wed, 04 May 2016 07:23 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
Hi Christian,

Do I need to mention all those I required in category.xml?
Re: Eclipse Plugin Install Error [message #1731287 is a reply to message #1731284] Wed, 04 May 2016 07:24 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
is it working if you remove it? do you have a updatesite for xtext added to your target eclipse? is xtext already installed there?

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Eclipse Plugin Install Error [message #1731288 is a reply to message #1731287] Wed, 04 May 2016 07:27 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
To install my plugin Do I need to xtext on customer IDE?
Re: Eclipse Plugin Install Error [message #1731289 is a reply to message #1731288] Wed, 04 May 2016 07:27 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
yes, at least parts of it.

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Eclipse Plugin Install Error [message #1731291 is a reply to message #1731289] Wed, 04 May 2016 07:31 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
why we need xtext installing on customer side, though my plugin developed from xtext ? Can you please explain?
Re: Eclipse Plugin Install Error [message #1731294 is a reply to message #1731291] Wed, 04 May 2016 07:37 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
xtext has parts that generate stuff, but xtext has api parts as well.
these api parts are not copied to each language but reused by all languages.
this is why you need e.g. the plugin org.eclipse.xtext in your target environment.

of couse you can e.g. add the xtext.sdk feature to the included features in the feature editor of your feature xml
or you simply add the xtext update site as well to your customer ide.

or .... (tons of options on how to deal with this)


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Eclipse Plugin Install Error [message #1731296 is a reply to message #1731294] Wed, 04 May 2016 07:54 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
Thanks for your valuable information
Re: Eclipse Plugin Install Error [message #1731304 is a reply to message #1731296] Wed, 04 May 2016 08:29 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
Hi Christian,


But the newly generated plugin is not working individually. If I install xtext plugin its working. Am I going in right direction? Can you please guide me?

[Updated on: Wed, 04 May 2016 09:35]

Report message to a moderator

Re: Eclipse Plugin Install Error [message #1731307 is a reply to message #1731304] Wed, 04 May 2016 08:33 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
org.eclipse.text is not org.eclipse.xtext

and there are others (ca 30) to add.

so did you add xtext.sdk to included features?


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Eclipse Plugin Install Error [message #1731316 is a reply to message #1731307] Wed, 04 May 2016 09:20 Go to previous messageGo to next message
RamaRao Nandamuri is currently offline RamaRao NandamuriFriend
Messages: 120
Registered: April 2016
Senior Member
It's a spelling mistake. I have added org.eclipse.xtext. I didn't see xtext.sdk there in the list. Do I need to install 30 more packages?
Re: Eclipse Plugin Install Error [message #1731318 is a reply to message #1731316] Wed, 04 May 2016 09:23 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13207
Registered: July 2009
Senior Member
yes i have no complete list.

thus simply add the sdk to the feature, p2 will then pick what it needs


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:What to commit
Next Topic:Change the "Xtext Task" in Task Browser
Goto Forum:
  


Current Time: Wed Nov 20 06:28:48 GMT 2019

Powered by FUDForum. Page generated in 0.03068 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top