Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Mars.2 splash screen(Mars.2 splash screen lost)
Mars.2 splash screen [message #1731250] Tue, 03 May 2016 18:54 Go to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
Two different installations of Mars.2 lost the splash screen on a recent update.
Is this maybe an Oomph error?

Both installations are Mars 4.5.2 20160218-0600, one on OS X 10.9.5 and the other on Kubuntu Linux 14.04 LTS.


--

Tauno Voipio
Re: Mars.2 splash screen [message #1731290 is a reply to message #1731250] Wed, 04 May 2016 07:29 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30451
Registered: July 2009
Senior Member
Tauno,

It's not clear how you installed it, what you did to update it, and what
a "lost splash screen" means exactly. I assume it still runs okay? If
it's just a "Check for Updates" being used, I don't see how Oomph would
be involved...


On 03.05.2016 20:54, Tauno Voipio wrote:
> Two different installations of Mars.2 lost the splash screen on a
> recent update.
> Is this maybe an Oomph error?
>
> Both installations are Mars 4.5.2 20160218-0600, one on OS X 10.9.5
> and the other on Kubuntu Linux 14.04 LTS.
>
Re: Mars.2 splash screen [message #1731338 is a reply to message #1731290] Wed, 04 May 2016 12:40 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
It was just 'Check for updates'. I suspected Oomph, as it is included in the installed Mars releases and there has been plenty of updates into it.

Both Mars copies were initially installed using the Oomph installer, and then the optional packages added with package list (.p2f) taken from the previous Luna installation.


--

Tauno Voipio
Re: Mars.2 splash screen [message #1731349 is a reply to message #1731338] Wed, 04 May 2016 13:31 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30451
Registered: July 2009
Senior Member
Tauno,

The splash screen stuff is very low level and controlled by
platform-specific code so I'm not sure how updates could disable that.
Certainly the splash screen is being handled and shown long before any
Oomph plugins could activate to have any impact. I've been updating
all my installations for along time, and they all still show splash
screens, at least on Windows.


On 04.05.2016 14:40, Tauno Voipio wrote:
> It was just 'Check for updates'. I suspected Oomph, as it is included
> in the installed Mars releases and there has been plenty of updates
> into it.
>
> Both Mars copies were initially installed using the Oomph installer,
> and then the optional packages added with package list (.p2f) taken
> from the previous Luna installation.
>
Re: Mars.2 splash screen [message #1731353 is a reply to message #1731349] Wed, 04 May 2016 14:15 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
Thanks, Ed.

Any pointers how to look for it?

There is also a Java upgrade from Oracle, but if it's there, it should affect others, too. The current Java is 1.8.0_91-b14, Version 8 Update 91.



--

Tauno Voipio
Re: Mars.2 splash screen [message #1731375 is a reply to message #1731353] Wed, 04 May 2016 16:54 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6445
Registered: July 2009
Senior Member
Am 04.05.2016 um 16:15 schrieb Tauno Voipio:
> Thanks, Ed.
>
> Any pointers how to look for it?
What is the value of the "osgi.splashPath" property in your eclipse/configuration/config.ini file?

Does it change during your suspicious update?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: Mars.2 splash screen [message #1731384 is a reply to message #1731375] Wed, 04 May 2016 19:46 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
Hello Eike,

Thank you for the help.

Sorry, I cannot repeat the update, as it is already done on both Mars.1 I had, so I do not know. Is there a way to look for the file from the information in the configuration? It seems that it is not a normal file system path.

Here are the configuration files from both installations:

OS X:
=====

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Tue May 03 21:18:55 EEST 2016
org.eclipse.update.reconcile=false
eclipse.p2.profile=_Users_tauno_Eclipse_java-latest-released_Eclipse.app_Contents_Eclipse
osgi.instance.area.default=@user.home/Documents/workspace
osgi.framework=file\:../../../../../.p2/pool/plugins/org.eclipse.osgi_3.10.102.v20160118-1700.jar
equinox.use.ds=true
eclipse.buildId=4.5.2.M20160212-1500
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.1.100.v20150423-1455.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=org.eclipse.platform.ide
osgi.configuration.cascaded=false
osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
osgi.framework.extensions=reference\:file\:org.eclipse.osgi.compatibility.state_1.0.100.v20150402-1551.jar
osgi.bundles.defaultStartLevel=4
eclipse.application=org.eclipse.ui.ide.workbench
eclipse.p2.data.area=file\:/Users/tauno/.p2/


----------------------

Linux (Kubuntu 14.04 LTS):
==========================

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Tue May 03 21:12:26 EEST 2016
org.eclipse.update.reconcile=false
eclipse.p2.profile=_home_tauno_eclipse_cpp-latest-released2_eclipse
osgi.instance.area.default=@user.home/workspace
osgi.framework=file\:../../../.p2/pool/plugins/org.eclipse.osgi_3.10.102.v20160118-1700.jar
equinox.use.ds=true
eclipse.buildId=4.5.2.M20160212-1500
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.1.100.v20150423-1455.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=org.eclipse.platform.ide
osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
osgi.framework.extensions=reference\:file\:org.eclipse.osgi.compatibility.state_1.0.100.v20150402-1551.jar
osgi.bundles.defaultStartLevel=4
eclipse.p2.data.area=file\:/home/tauno/.p2/
eclipse.application=org.eclipse.ui.ide.workbench


--

Tauno Voipio
Re: Mars.2 splash screen [message #1731430 is a reply to message #1731384] Thu, 05 May 2016 08:14 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30451
Registered: July 2009
Senior Member
Tauno,

This appears to be a bug in p2 itself. I've opened
https://bugs.eclipse.org/bugs/show_bug.cgi?id=493050


On 04.05.2016 21:46, Tauno Voipio wrote:
> Hello Eike,
>
> Thank you for the help.
>
> Sorry, I cannot repeat the update, as it is already done on both
> Mars.1 I had, so I do not know. Is there a way to look for the file
> from the information in the configuration? It seems that it is not a
> normal file system path.
>
> Here are the configuration files from both installations:
>
> OS X:
> =====
>
> #This configuration file was written by:
> org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
> #Tue May 03 21:18:55 EEST 2016
> org.eclipse.update.reconcile=false
> eclipse.p2.profile=_Users_tauno_Eclipse_java-latest-released_Eclipse.app_Contents_Eclipse
>
> osgi.instance.area.default=@user.home/Documents/workspace
> osgi.framework=file\:../../../../../.p2/pool/plugins/org.eclipse.osgi_3.10.102.v20160118-1700.jar
>
> equinox.use.ds=true
> eclipse.buildId=4.5.2.M20160212-1500
> osgi.bundles=reference\:file\:mailto:org.eclipse.equinox.simpleconfigurator_1.1.100.v20150423-1455.jar@1\:start
>
> org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
>
> eclipse.product=org.eclipse.platform.ide
> osgi.configuration.cascaded=false
> osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
> osgi.framework.extensions=reference\:file\:org.eclipse.osgi.compatibility.state_1.0.100.v20150402-1551.jar
>
> osgi.bundles.defaultStartLevel=4
> eclipse.application=org.eclipse.ui.ide.workbench
> eclipse.p2.data.area=file\:/Users/tauno/.p2/
>
>
> ----------------------
>
> Linux (Kubuntu 14.04 LTS):
> ==========================
>
> #This configuration file was written by:
> org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
> #Tue May 03 21:12:26 EEST 2016
> org.eclipse.update.reconcile=false
> eclipse.p2.profile=_home_tauno_eclipse_cpp-latest-released2_eclipse
> osgi.instance.area.default=@user.home/workspace
> osgi.framework=file\:../../../.p2/pool/plugins/org.eclipse.osgi_3.10.102.v20160118-1700.jar
>
> equinox.use.ds=true
> eclipse.buildId=4.5.2.M20160212-1500
> osgi.bundles=reference\:file\:mailto:org.eclipse.equinox.simpleconfigurator_1.1.100.v20150423-1455.jar@1\:start
>
> org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
>
> eclipse.product=org.eclipse.platform.ide
> osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
> osgi.framework.extensions=reference\:file\:org.eclipse.osgi.compatibility.state_1.0.100.v20150402-1551.jar
>
> osgi.bundles.defaultStartLevel=4
> eclipse.p2.data.area=file\:/home/tauno/.p2/
> eclipse.application=org.eclipse.ui.ide.workbench
>
Re: Mars.2 splash screen [message #1731431 is a reply to message #1731430] Thu, 05 May 2016 08:17 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
Thanks, Ed!

Eike: Sorry for barking up the wrong tree.


--

Tauno Voipio
Re: Mars.2 splash screen [message #1731439 is a reply to message #1731431] Thu, 05 May 2016 09:22 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6445
Registered: July 2009
Senior Member
Am 05.05.2016 um 10:17 schrieb Tauno Voipio:
> Thanks, Ed!
>
> Eike: Sorry for barking up the wrong tree.
No need to worry! It was a perfect hint because the problematic scenario (installation location != bundle pool location)
is way more common with Oomph-installed products and so we might have a chance to get the underlying problem fixed in p2.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: Mars.2 splash screen [SOLVED] [message #1732242 is a reply to message #1731439] Fri, 13 May 2016 18:21 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
I managed to get the splash screens back by a Windows-style repair:

1. Export installed modules to a file
2. Remove current installation
3. Install a base system with Oomph (I used C/C++ package)
4. Start the installed system and import modules with file from point 1

Thanks for the pointers!



--

Tauno Voipio
Re: Mars.2 and Neon splash screen [SOLVED] [message #1733842 is a reply to message #1732242] Wed, 01 June 2016 12:00 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
Neon did it again: On an update with the installed Neon, the splash screen got lost. A re-install repaired the thing. It seems that the bug is still there.


--

Tauno Voipio
Previous Topic:How to multi-user windows installation?
Next Topic:Unable to start Eclipse
Goto Forum:
  


Current Time: Thu Sep 19 08:16:06 GMT 2019

Powered by FUDForum. Page generated in 0.04029 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top