Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » FIles in $HOME/.p2 repo corrupted, but bundle analyzer finds nothing wrong
FIles in $HOME/.p2 repo corrupted, but bundle analyzer finds nothing wrong [message #1730962] Sat, 30 April 2016 22:18 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 559
Registered: July 2009
Senior Member
I'm seeing some odd errors trying to update my Eclipse instance on my HP Zbook Centos laptop.

When I select "Check for Updates", nothing happens. When I look in the log, I see errors like this:
org.eclipse.oomph.util.ReflectUtil$ReflectionException: org.eclipse.oomph.util.IORuntimeException: The file /home/opnfv/frameworks/eclipse/p2/org.eclipse.equinox.p2.engine/profileRegistry/epp.package.java.profile/1461938318659.profile.gz of length 0 failed to load properly
	at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:130)


I verified that this is a zero-length file.

Ok, I recently learned about the Oomph bundler analyzer, because I had a similar problem a couple of months ago (https://www.eclipse.org/forums/index.php/mv/msg/1074901/1723920/#msg_1723920).

However, when I ran the bundle analyzer, it didn't find any damaged artifacts.
Re: FIles in $HOME/.p2 repo corrupted, but bundle analyzer finds nothing wrong [message #1730966 is a reply to message #1730962] Sun, 01 May 2016 07:05 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29390
Registered: July 2009
Senior Member
David,

It's only checking the artifacts in the pool for damage, not the profile
itself. Please open a Bugzilla against
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Oomph. It should be
possible to partially restore the installation by deleting the profile
assuming there is an older "backup" version of the profile. Is this
profile nested in the bundle pool or within the installation folder?


On 01.05.2016 00:18, David M. Karr wrote:
> I'm seeing some odd errors trying to update my Eclipse instance on my
> HP Zbook Centos laptop.
>
> When I select "Check for Updates", nothing happens. When I look in
> the log, I see errors like this:
> org.eclipse.oomph.util.ReflectUtil$ReflectionException:
> org.eclipse.oomph.util.IORuntimeException: The file
> /home/opnfv/frameworks/eclipse/p2/org.eclipse.equinox.p2.engine/profileRegistry/epp.package.java.profile/1461938318659.profile.gz
> of length 0 failed to load properly
> at
> org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:130)
>
>
> I verified that this is a zero-length file.
>
> Ok, I recently learned about the Oomph bundler analyzer, because I had
> a similar problem a couple of months ago
> (https://www.eclipse.org/forums/index.php/mv/msg/1074901/1723920/#msg_1723920).
>
> However, when I ran the bundle analyzer, it didn't find any damaged
> artifacts.
Re: FIles in $HOME/.p2 repo corrupted, but bundle analyzer finds nothing wrong [message #1730984 is a reply to message #1730966] Sun, 01 May 2016 15:41 Go to previous message
David M. Karr is currently offline David M. KarrFriend
Messages: 559
Registered: July 2009
Senior Member
Ok, submitted: https://bugs.eclipse.org/bugs/show_bug.cgi?id=492778 .

To your question, this is inside the installation tree, not my workspace. I'm guessing the bundle pool goes inside the workspace.

I have no idea whether there is a backup of the profile.
Previous Topic:RSE passwords
Next Topic:Get IDocument from IFile
Goto Forum:
  


Current Time: Fri Jun 22 09:46:30 GMT 2018

Powered by FUDForum. Page generated in 0.03255 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top