Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Acceleo does not regenerate
Acceleo does not regenerate [message #1730955] Sat, 30 April 2016 16:27 Go to next message
Mr Cur is currently offline Mr CurFriend
Messages: 31
Registered: September 2014
Member
Hi all,

I use Eclipse Mars and Acceleo 3.6.
To generate code, I use the Runner "Java Application" as "Acceleo plug in" seems not to work in Mars.

I have annotated classes etc with the @generated tag. However, the code with these annotations are not regenerated at all.

For instance:
@Stateless
@TransactionManagement(value = TransactionManagementType.CONTAINER)
@TransactionAttribute(TransactionAttributeType.REQUIRES_NEW)
/**
* @generated
*/
public class [anEClass.queryClassName()/]ServiceBean extends [anEClass.eSuperTypes->first().name.toUpperFirst()/]ServiceBean
implements [anEClass.queryClassName()/]Service {
}

generates code the first time.
If I however change the template in

@Stateless
@TransactionManagement(value = TransactionManagementType.CONTAINER)
@TransactionAttribute(TransactionAttributeType.REQUIRES_NEW)
/**
* @generated
*/
public class [anEClass.queryClassName()/]ServiceBean extends [anEClass.eSuperTypes->first().name.toUpperFirst()/]ServiceBean
implements [anEClass.queryClassName()/]Service {
XXX
}

the code is not regenerated.

What am I doing wrong here?

Best,

Cur
Re: Acceleo does not regenerate [message #1730956 is a reply to message #1730955] Sat, 30 April 2016 16:58 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12241
Registered: July 2009
Senior Member
Btw do you know you can have semantic validation as well? You don't have to
do everything in the grammar


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Acceleo does not regenerate [message #1730957 is a reply to message #1730956] Sat, 30 April 2016 16:58 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 12241
Registered: July 2009
Senior Member
Christian Dietrich <no_email@xxxxxxxxd> wrote:
> Btw do you know you can have semantic validation as well? You don't have to
> do everything in the grammar
>

Sry wrong thread


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Acceleo does not regenerate [message #1730959 is a reply to message #1730955] Sat, 30 April 2016 18:00 Go to previous messageGo to next message
Mr Cur is currently offline Mr CurFriend
Messages: 31
Registered: September 2014
Member
Using the Acceleo plugin (see http://stackoverflow.com/questions/23900256/acceleo-code-generation-doesnt-start-couldnt-load-main-class) regeneration succeeds.

Is there something required (e.g. inclusion of Jmerge or so) to use the the Runner "Java Application"?
Re: Acceleo does not regenerate [message #1732586 is a reply to message #1730959] Wed, 18 May 2016 11:31 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1858
Registered: July 2009
Senior Member
Hi,

Acceleo disables calls to JMerge when running in standalone ("java application"). This is due to our still supporting Eclipse 3.5 whilst JMerge was causing failures in that version of Eclipse. You can look at the solution from Vincent Aranega on this earlier thread : you'll have to create a new generation strategy that does call JMerge even in standalone (it is possible now that JMerge has fixed its previous bugs).

Laurent Goubet
Obeo
Previous Topic:Cannot Access Stereotypes
Next Topic:Loop in Acceleo
Goto Forum:
  


Current Time: Tue Sep 25 08:49:17 GMT 2018

Powered by FUDForum. Page generated in 0.02303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top