Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Export 3.x product wizard problems
Export 3.x product wizard problems [message #1730147] Thu, 21 April 2016 18:24 Go to next message
frank b is currently offline frank bFriend
Messages: 45
Registered: July 2009
Member
Hello,

I am facing a RCP 3.x application (multiple platform) export errors that I have not been able to solve.
I am using OS X El Capitan with Eclipse Mars.2 and java 1.8.0_77-b03.

Any help would be very appreciated. Thanks in advance Smile !

Here are steps that could be used in order to reproduce the problem, I hope :

1) Download eclipse 4.5.2 for OS X from :

http://download.eclipse.org/eclipse/downloads/drops4/R-4.5.2-201602121500/

2) Edit running target platform to add delta pack repository following these instructions :

https://wiki.eclipse.org/Building#Preferred_way_of_doing_multi-platform_builds

and using this software site url :

http://download.eclipse.org/eclipse/updates/4.5

3) Create an eclipse RCP 3.x application (minimal)

4) Launch as Eclipse application => Ok

5) Create product configuration from this previous launch configuration then launch product => Ok

6) Export for OS X only :

Don't work because export is not properly done. Contents directory of the .app Mac OS X folder is not created.

7) Export for other platform :

I get this error in Problem Occurred dialog :

'Export Product' has encountered a problem
Cannot complete the install because one or more required items could not be found.
Software being installed: testRCPProduct 0.0.0 (testRCP.product 0.0.0)
Missing requirement for filter properties ~= $0: Standard Widget Toolkit 3.104.2.v20160212-1350 (org.eclipse.swt 3.104.2.v20160212-1350) requires 'org.eclipse.swt.win32.win32.x86 [3.104.2.v20160212-1350]' but it could not be found
Cannot satisfy dependency:
Cannot satisfy dependency:
Cannot satisfy dependency:

[Updated on: Thu, 21 April 2016 18:42]

Report message to a moderator

Re: Export 3.x product wizard problems [message #1730164 is a reply to message #1730147] Fri, 22 April 2016 01:55 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 877
Registered: January 2012
Senior Member

The Product > Export uses PDE/Build, which is aged and not a recommended build process any more. When PDE/Build works, it's slow. When it doesn't work, it's nearly impossible to diagnose.

Save yourself grief and follow the advice further up on https://wiki.eclipse.org/Building and use Tycho to do your build. There's some up-front cost to setting up your build, but you then have a reproducible build formula that's far easier to diagnose. And Tycho is also much faster than PDE/Build: one of my clients had a build go from 2 hours with Product > Export to 7 minutes with Tycho.

Brian.
Re: Export 3.x product wizard problems [message #1730311 is a reply to message #1730164] Sun, 24 April 2016 10:31 Go to previous message
frank b is currently offline frank bFriend
Messages: 45
Registered: July 2009
Member
Brian,

thanks a lot for your advice. I've followed many web tutorial specially this one and I've been able to build my application.

I still have a problem for multiplatform building but so far so good...

thanks.
Previous Topic:Eclipse Toolbar
Next Topic:XML editor embedded in a MultiPageEditor
Goto Forum:
  


Current Time: Fri Nov 27 19:03:03 GMT 2020

Powered by FUDForum. Page generated in 0.01921 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top