Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » MoDisco » KDM to UML does not work
KDM to UML does not work [message #1729968] Wed, 20 April 2016 15:28 Go to next message
Francesco Mazzei is currently offline Francesco MazzeiFriend
Messages: 2
Registered: April 2016
Junior Member
Hi,

I need to use MoDisco on a simple J2EE Project (an university project) to extract the KDM and the UML model. When I try to extract the UML from the KDM (that MoDisco correctly extract), MoDisco does not provide any result or error. I have already set the "SERIALIZE_TARGET" on true.

However, using a simple java program, it runs without issues.

I have tried to use Mars and Luna, but nothing change.

Have you some explanations about this?

Thanks!

Francesco
Re: KDM to UML does not work [message #1730107 is a reply to message #1729968] Thu, 21 April 2016 11:55 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo BruneliereFriend
Messages: 667
Registered: July 2009
Senior Member
Hello,

Thanks for trying out MoDisco and its model discoverers.
From your post, it is not clear which error you actually get: have you looked to the Error Log?

Kind regards,


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: KDM to UML does not work [message #1730190 is a reply to message #1730107] Fri, 22 April 2016 08:04 Go to previous messageGo to next message
Francesco Mazzei is currently offline Francesco MazzeiFriend
Messages: 2
Registered: April 2016
Junior Member
Hi,

The console does not provide errors, but the Error Log gives this:

"
Cannot set feature uml!InterfaceRealization.contract to value org.eclipse.emf.ecore.impl.DynamicEObjectImpl@5eead8a (eClass: org.eclipse.emf.ecore.impl.EClassImpl@265093f2 (name: Class) (instanceClassName: null) (abstract: false, interface: false)) (org.eclipse.modisco.kdm.uml2converter_0.13.2.201601200708)

"
Re: KDM to UML does not work [message #1730477 is a reply to message #1730190] Tue, 26 April 2016 08:32 Go to previous message
Hugo Bruneliere is currently offline Hugo BruneliereFriend
Messages: 667
Registered: July 2009
Senior Member
Hi,

Could you raise a corresponding bug providing all the needed information/data to reproduce the error?
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=MDT.MoDisco&component=Technologies
Thanks in advance.


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Previous Topic:Some 'calls' are lost
Next Topic:get the main thread from java model
Goto Forum:
  


Current Time: Wed Jan 17 22:18:57 GMT 2018

Powered by FUDForum. Page generated in 0.02036 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software