Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Tab Sequence properties is not working properly(in plug in extension point tab separator using it was not working module to module )
Tab Sequence properties is not working properly [message #1728431] Mon, 04 April 2016 10:47 Go to next message
surekha somisetty is currently offline surekha somisettyFriend
Messages: 18
Registered: April 2016
Junior Member

I am extend my propertyTabs like that. it was working when i am run my project at 1st time . next time it was not working what ever i am given ordered. please let me know whats my error. if any missing please suggest me.

<extension
point="org.eclipse.ui.views.properties.tabbed.propertyTabs">
<propertyTabs
contributorId="org.eclipse.ui.tests.views.properties.tabbed.views.TestsView">
<propertyTab
afterTab="car.editors.HardwareDescription"
category="first"
id="car.view.HardwareElements"
indented="true"
label="Design Hierarchy">
</propertyTab>
<propertyTab
afterTab="car.views.HardwareElementFuctionality"
category="CAR Tool.propertyTab8"
id="car.editors.HardwareDescription"
image="icons/HW.png"
indented="true"
label="HW Description">
</propertyTab>
<propertyTab
afterTab="car.view.ErrorLogs"
category="second"
id="car.views.HardwareElementFuctionality"
indented="true"
label="Hardware Element Fuctionality">
</propertyTab>
<propertyTab
afterTab="car.view.AuditLogs"
category="third"
id="car.view.HardwareElements"
indented="false"
label="Hardware Elements">
</propertyTab>
<propertyTab
afterTab="car.view.HardwareElements"
category="fourth"
id="car.view.ErrorLogs"
indented="false"
label="Error Logs">
</propertyTab>
</propertyTabs>
</extension>

[Updated on: Tue, 05 April 2016 07:37]

Report message to a moderator

Re: Tab Separator properties is not working properly [message #1728468 is a reply to message #1728431] Mon, 04 April 2016 15:00 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 680
Registered: January 2012
Senior Member

Do you mean the order of the property tabs is inconsistent? There is an open bug but the contributed fix isn't quite sufficient.

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: Tab Sequence properties is not working properly [message #1728505 is a reply to message #1728468] Tue, 05 April 2016 05:41 Go to previous message
surekha somisetty is currently offline surekha somisettyFriend
Messages: 18
Registered: April 2016
Junior Member
Sorry mr! Brian de AlwisFriend,
I am not get in your point. please let me clear explanation.
i am given that order in one of my module . when i am entered into that module i.e 1st time it is working. but when i came back another module to this old module it was not working . it's behave 's a eclipse by default . hear my window have one editor part and 4 view parts. please give me clear example.


in want to move my tab to design hierarchy ---> Hardware Description --> Hardware Element functionality ----> Error logs

how to fix tab ordered.

How to set my tab sequence .




Thanks .

  • Attachment: hardware.jpg
    (Size: 117.62KB, Downloaded 167 times)

[Updated on: Tue, 05 April 2016 07:37]

Report message to a moderator

Previous Topic:Sample ipe module doesnt build
Next Topic:ToolbarItems flicker with VisibleWhen rules
Goto Forum:
  


Current Time: Wed Nov 22 01:56:29 GMT 2017

Powered by FUDForum. Page generated in 0.01585 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software