Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OM2M » Cannot find "Maven ~> Install " in eclipse and cannot configure.(Cannot find "Maven ~> Install " and "org.om2m.site.nscl.....")
Cannot find "Maven ~> Install " in eclipse and cannot configure. [message #1727829] Mon, 28 March 2016 09:14 Go to next message
Muhammad Shoaib is currently offline Muhammad ShoaibFriend
Messages: 21
Registered: March 2016
Junior Member
Hi,
I am new to om2m. I followed the steps got the ide and maven and git. Now in the page "Clone and Build" the step "Build OM2M using Eclipse" I cannot find maven ~> install when I right click on the project. I have the maven installed I used the command line to tackle this problem.
Now next instruction of OM2M Configuration I cannot find the directory "om2m/org.eclipse.om2m/org.eclipse.om2m.site.nscl/target/products/nscl/<os>/<ws>/<arch>" . Please help!!! I have attached a picture which shows the folders in the directory "org.eclipse.om2m"
Sorry for any inconvenience and thank you for your time
index.php/fa/25443/0/
  • Attachment: Untitled.png
    (Size: 59.63KB, Downloaded 380 times)
Re: Cannot find "Maven ~> Install " in eclipse and cannot configure. [message #1727835 is a reply to message #1727829] Mon, 28 March 2016 10:14 Go to previous messageGo to next message
Mahdi Ben Alaya is currently offline Mahdi Ben AlayaFriend
Messages: 227
Registered: November 2013
Senior Member
Hello Muhammad,

1) To build the project using Eclipse you should right click on the "org.eclipse.om2m" package, then Select "Run as", then click on "maven install". It should work for you since this is related to the Eclipse IDE maven not the OM2M project.
2) We recently adapted our wiki with the new version of OM2M which is now compliant with the oneM2M standard (http://www.onem2m.org). Please check the new links from our official web site at: http://om2m.org.

Thank you for your interest
Re: Cannot find "Maven ~> Install " in eclipse and cannot configure. [message #1727887 is a reply to message #1727835] Tue, 29 March 2016 04:16 Go to previous messageGo to next message
Muhammad Shoaib is currently offline Muhammad ShoaibFriend
Messages: 21
Registered: March 2016
Junior Member
Thank you for quick response and for the help of course. but the eclipse problem still exist I'll attach a screenshot to show the problem. Also I am new to eclipse so forgive me if I am being stupid Laughing
index.php/fa/25456/0/
  • Attachment: Untitled.png
    (Size: 50.60KB, Downloaded 595 times)
Re: Cannot find "Maven ~> Install " in eclipse and cannot configure. [message #1728006 is a reply to message #1727887] Wed, 30 March 2016 08:08 Go to previous messageGo to next message
Mahdi Ben Alaya is currently offline Mahdi Ben AlayaFriend
Messages: 227
Registered: November 2013
Senior Member
Dear Muhammad,

You forget to do this step of this tutorial: https://wiki.eclipse.org/OM2M/one/Clone :
Git clone
In the third page, check the "import all existing projects after clone finishes" and click "Finish".

You need to import the project in your workspace.

Mahdi
Re: Cannot find "Maven ~> Install " in eclipse and cannot configure. [message #1728013 is a reply to message #1728006] Wed, 30 March 2016 09:12 Go to previous messageGo to next message
Muhammad Shoaib is currently offline Muhammad ShoaibFriend
Messages: 21
Registered: March 2016
Junior Member
Thanks for the reply but that wasn't the issue I did that step and was looking for maven install in the wrong place. sorry I am new to eclipse ide. I just needed to see the "packages" then rather then repository.
Thank you for your time
Re: Cannot find "Maven ~> Install " in eclipse and cannot configure. [message #1728015 is a reply to message #1728013] Wed, 30 March 2016 09:13 Go to previous message
Mahdi Ben Alaya is currently offline Mahdi Ben AlayaFriend
Messages: 227
Registered: November 2013
Senior Member
You are welcome.

Mahdi
Previous Topic:IN-IP address wont change
Next Topic:Communication between two machines
Goto Forum:
  


Current Time: Wed Sep 26 12:28:50 GMT 2018

Powered by FUDForum. Page generated in 0.02901 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top