Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Viewpoint new diagram menu greyed out(Issue with creating a new viewpoint and not being able to create a diagram.)
Viewpoint new diagram menu greyed out [message #1727477] Wed, 23 March 2016 10:18
Daniel Clarke is currently offline Daniel ClarkeFriend
Messages: 24
Registered: March 2016
Junior Member
Hi,

I'm trying to create a custom viewpoint; I've followed the instructions in the help chapter but when I try to create a diagram the option is greyed out.

I created the viewpoint configuration and within the view created a child diagram based on "PapyrusUMLClassDiagram". I then added a Model rule, Owner rule and Child rule as described in the help documentation (to allow me to create under a package with all model elements allowed for now - but I am wanting to restrict this eventually).

I've then set it as the current viewport in Eclipse through the Viewpoints Configuration menu (as a Manual configuration selection and pointing it at the configuration file within my workspace). However, as soon as I do this I cannot create a diagram as the option is greyed out. Also, if I open the Viewpoint Explorer window it is empty.

I do not know if I have missed something in my configuration or if there is an error when I load the viewport or something but I am now stuck and not sure what to try.

Any help would be appreciated. I've attached showing what I have done - I could post the configuration if that helps?

Regards,
Dan
Previous Topic:Setting initlai size of elements in diagrams
Next Topic:Undo Problem: AppliedStereotypeCommentEditPolicy
Goto Forum:
  


Current Time: Fri Jul 10 13:58:12 GMT 2020

Powered by FUDForum. Page generated in 0.02760 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top