Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installed plugin, now eclipse (mars) wont start
Installed plugin, now eclipse (mars) wont start [message #1725502] Thu, 03 March 2016 22:13 Go to next message
daniel alvarez is currently offline daniel alvarezFriend
Messages: 1
Registered: March 2016
Junior Member
I installed a plugin for viewing json files, its the "json tool" by sweetlemonade.

Anyway, after installing it I tried to view a json file (very large file) which I thought the plugin might be able to handle. Well, eclipse crashed when I did this. Now I can't get eclipse to start again. it fails when it gets to "loading org.sweetlemonade.eclipse.json"

I've searched for answers on stackoverflow but the accepted answers include using "p2 director" to uninstall the plugin via command line. The only problem is the answer is for an old version of eclipse. I'm using eclipse mars an can't find an install for "p2 director" anywhere.

How can I uninstall this plugin manually and get eclipse to run again?
Re: Installed plugin, now eclipse (mars) wont start [message #1725557 is a reply to message #1725502] Fri, 04 March 2016 11:31 Go to previous message
Felix Dorner is currently offline Felix DornerFriend
Messages: 363
Registered: December 2015
Senior Member
On 04-Mar-16 09:45, daniel alvarez wrote:
> I installed a plugin for viewing json files, its the "json tool" by
> sweetlemonade.
>
> Anyway, after installing it I tried to view a json file (very large
> file) which I thought the plugin might be able to handle. Well, eclipse
> crashed when I did this. Now I can't get eclipse to start again. it
> fails when it gets to "loading org.sweetlemonade.eclipse.json"
>
> I've searched for answers on stackoverflow but the accepted answers
> include using "p2 director" to uninstall the plugin via command line.
> The only problem is the answer is for an old version of eclipse. I'm
> using eclipse mars an can't find an install for "p2 director" anywhere.
>
> How can I uninstall this plugin manually and get eclipse to run again?

Did you try to start eclipse with a different workspace?
Previous Topic:Brand New User - Installation help
Next Topic:Windows VS Linux Eclipse JavaEE UI appears different
Goto Forum:
  


Current Time: Fri Oct 23 06:28:34 GMT 2020

Powered by FUDForum. Page generated in 0.02614 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top