Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Serialized UML sequence diagram issue(Attributes missing when diagrams are serialized into XMI)
Serialized UML sequence diagram issue [message #1724946] Sat, 27 February 2016 15:31 Go to next message
Thomas Wienke is currently offline Thomas WienkeFriend
Messages: 1
Registered: February 2016
Junior Member
Hello,
I am trying to analyze serialized XMI of sequence diagrams, because I need to generate code from it, although I think there are some bugs with sequence diagrams serialization. In the attached picture I am trying to create a self-message on lifeline, but the attribute covered is not serialized on the Execution Specification Block. When I validate the diagram, it gives me these 2 errors:

The feature 'uml::InteractionFragment::covered' of 'RootElement::Interaction1::BehaviorExecSpec2Finish' with 0 values must have at least 1 values
The feature 'uml::InteractionFragment::covered' of 'RootElement::Interaction1::setChanged_MessageRecv' with 0 values must have at least 1 values


Sometimes it's serialized without errors, but the most of the times it's not, therefore I am not able to analyze XMI programatically. I tried Papyrus version 0.10 under Kepler and everything seems fine, but in this older version I am not able to create Lifeline that represents the whole class, only property and that is not acceptable for me.

So my question is, is this some sort of a bug or am I doing something wrong? thanks
  • Attachment: sd_issue.png
    (Size: 10.58KB, Downloaded 383 times)
Re: Serialized UML sequence diagram issue [message #1725022 is a reply to message #1724946] Mon, 29 February 2016 07:56 Go to previous message
Marc-Florian Wendland is currently offline Marc-Florian WendlandFriend
Messages: 81
Registered: January 2013
Member
Hi Thomas,

in particular the sequence diagrams capabilities of Papyrus are not very mature and reliable. It improved a little in Luna and Mars, but it is still far away from being convenient.

The first problem you reported is not an XMI issue, but a SD issue. I am pretty sure that the attributed covered is already missing in the model. This happens sometimes in the older versions of Papyrus, but I do not why and when.

HTH,
Marc-Florian
Previous Topic:StateMachine generation programmatically - shrinking states
Next Topic:Severe bug in Profile Diagram
Goto Forum:
  


Current Time: Sat Jul 11 17:39:04 GMT 2020

Powered by FUDForum. Page generated in 0.01828 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top