Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Attaching to process: Not suspending the process(Even when disabling Stop at startup, all threads gets suspended on attaching)
Attaching to process: Not suspending the process [message #1724420] Tue, 23 February 2016 19:56 Go to next message
Marc Kunze is currently offline Marc KunzeFriend
Messages: 6
Registered: May 2014
Junior Member
Even when disabling Stop at startup, all threads gets suspended after attaching.

I have found the bug report on https://bugs.eclipse.org/bugs/show_bug.cgi?id=333284#c19 (the last comment).
Has there been any work on this feature?
How can I resume all threads after attaching automatically?

Edit: Non-stop mode does not make any difference. But given that Non-stop mode requires special support from gdb, I feel like these are two different features anyway.

Thank you very much in advance.

Marc

[Updated on: Tue, 23 February 2016 20:05]

Report message to a moderator

Re: Attaching to process: Not suspending the process [message #1724433 is a reply to message #1724420] Tue, 23 February 2016 22:16 Go to previous message
Jonah Graham is currently offline Jonah GrahamFriend
Messages: 400
Registered: June 2014
Senior Member
I don't think there has been any work on the feature, I would recommend pulling Marc Khouzam comment + your feature request into a new bug to show community interest.

Previous Topic:Selecting file from Search panel overwrites previous file
Next Topic:Final Launch Sequence
Goto Forum:
  


Current Time: Fri Jun 22 13:17:10 GMT 2018

Powered by FUDForum. Page generated in 0.01425 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top