Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Buckminster adds version ranges to my plugins when building p2 site
Buckminster adds version ranges to my plugins when building p2 site [message #1723376] Mon, 15 February 2016 09:29 Go to next message
Felix Dorner is currently offline Felix DornerFriend
Messages: 276
Registered: December 2015
Senior Member
Hi,

In my plugins i never add a required version for a dependency. Now, when
I build a p2 site with buckminster, when I look in the resulting plugin
..jar files, there suddenly _are_ version ranges. Why does this happen?
Is there a way to avoid this?

Thanks for explanation.
Felix
Re: Buckminster adds version ranges to my plugins when building p2 site [message #1723404 is a reply to message #1723376] Mon, 15 February 2016 12:19 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1751
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 15/02/2016 10:29, Felix Dorner wrote:
> Hi,
>
> In my plugins i never add a required version for a dependency. Now, when
> I build a p2 site with buckminster, when I look in the resulting plugin
> .jar files, there suddenly _are_ version ranges. Why does this happen?
> Is there a way to avoid this?
>
> Thanks for explanation.
> Felix

Hi

yes that's the default behavior, but you can tweak it; IIRC it is
documented here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=309147

cheers
Lorenzo

--
Prof. Lorenzo Bettini, Computer Science, DISIA, Univ. Firenze
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: Buckminster adds version ranges to my plugins when building p2 site [message #1723406 is a reply to message #1723404] Mon, 15 February 2016 12:22 Go to previous messageGo to next message
Felix Dorner is currently offline Felix DornerFriend
Messages: 276
Registered: December 2015
Senior Member
On 15-Feb-16 13:19, Lorenzo Bettini wrote:
> yes that's the default behavior, but you can tweak it; IIRC it is
> documented here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=309147

Nice! \o/ thank you Lorenzo!
Re: Buckminster adds version ranges to my plugins when building p2 site [message #1723408 is a reply to message #1723406] Mon, 15 February 2016 13:02 Go to previous message
Felix Dorner is currently offline Felix DornerFriend
Messages: 276
Registered: December 2015
Senior Member
On 15-Feb-16 13:22, Felix Dorner wrote:
> On 15-Feb-16 13:19, Lorenzo Bettini wrote:
>> yes that's the default behavior, but you can tweak it; IIRC it is
>> documented here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=309147
>
> Nice! \o/ thank you Lorenzo!
>
Ok so now I get the picture. These injected bundle requirements are then
also used to create the iu requires ranges in the site content.xml
Previous Topic:Can't install Buckminster
Next Topic:P2 update for RCP product fails
Goto Forum:
  


Current Time: Mon Oct 15 15:02:51 GMT 2018

Powered by FUDForum. Page generated in 0.02408 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top