Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » e4 RCP Application content not changing after first run
e4 RCP Application content not changing after first run [message #1723280] Sat, 13 February 2016 09:36 Go to next message
Sebastian Grams is currently offline Sebastian GramsFriend
Messages: 1
Registered: February 2016
Junior Member
Hello Everybody,

I'm new to e(fx)clipse, so tried out the tutorial #4 from the e(fx)clipse site. I creted a basic e4 rcp application project and everything worked fine until the first run. After that, none of the functionality I added (e.g. menu entries etc.) were visible in the running app.

Currently I am using e(fx)clipse v2.1.0. The target platform ist also v2.1.0. I don't know what mistake I made. Maybe it's just a little thing.

When I run my Project I get the following output:

!SESSION 2016-02-13 10:32:49.081 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_73
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments:  -product test.app.product
Command-line arguments:  -product test.app.product -data /Users/Basti/Documents/Programmierung/EclipseWorkspace/../runtime-test.app.product -dev file:/Users/Basti/Documents/Programmierung/EclipseWorkspace/.metadata/.plugins/org.eclipse.pde.core/test.app.product.product/dev.properties -consoleLog

!ENTRY org.eclipse.equinox.ds 1 0 2016-02-13 10:32:49.943
!MESSAGE Could not bind a reference of component org.eclipse.fx.core.internal.JUtilLoggerFactory. The reference is: Reference[name = registerHandler, interface = java.util.logging.Handler, policy = dynamic, policy-option = greedy, cardinality = 0..n, target = null, bind = registerHandler, unbind = unregisterHandler, updated = null]

!ENTRY org.eclipse.equinox.ds 1 0 2016-02-13 10:32:50.361
!MESSAGE Could not bind a reference of component test.app.themes.default. The reference is: Reference[name = Stylesheet, interface = org.eclipse.fx.ui.services.theme.Stylesheet, policy = dynamic, cardinality = 0..n, target = null, bind = registerStylesheet, unbind = unregisterStylesheet]


I hope somebody can help me this issue.
Re: e4 RCP Application content not changing after first run [message #1723340 is a reply to message #1723280] Sun, 14 February 2016 18:27 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6350
Registered: July 2009
Senior Member
e4 remembers the last state so you need to tell the it to forget about the last runs with:
A) Open the launchconfig and on the first page and check "clear" or
B) Open the Arguments tab an in the program Arguments field and -clearPersistedState at the end
Previous Topic:Replacing ISaveHandler default implementation
Next Topic:FXMLBuilder StackOverflowError
Goto Forum:
  


Current Time: Thu Aug 24 08:51:37 GMT 2017

Powered by FUDForum. Page generated in 0.05670 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software