Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed
ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1722746] Mon, 08 February 2016 19:14 Go to next message
Thibault Le Ouay is currently offline Thibault Le OuayFriend
Messages: 23
Registered: October 2014
Junior Member
Hey,

i'm trying to set up an eclipse platform UI install on a new computer but I get the following error

ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:688)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:974)
  at org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:119)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:910)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3036)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:2980)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4170)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4164)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4162)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2971)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2946)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2857)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:555)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:674)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
  ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__eclipse_UI_WS-68b9fddef2d38b9b8eb69e3bdc3759af24693dda, phase=org.eclipse.oomph.targlets.internal.core.TargletContainer$TargletCommitContext$3, operand=null --> [R]org.eclipse.equinox.executable_root.gtk.hpux.ia64 3.6.300.N20160207-2000, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
  ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed - file C:\eclipse\UI\WS\.metadata\.plugins\org.eclipse.pde.core\.install_folders\1454957901198\launcher does not exist


I dont get why it's looking for the gtk.hpux executable as i am on a windows 10 computer Sad
Also it works on a Windows 7 computer, is there anything i have forget to set ?


It looks similar to this post :
https://www.eclipse.org/forums/index.php/t/905967/

Hope you can help me.

Thanks

Thibault

[Updated on: Mon, 08 February 2016 19:15]

Report message to a moderator

Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1722783 is a reply to message #1722746] Tue, 09 February 2016 06:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31014
Registered: July 2009
Senior Member
How could I try to reproduce this? What steps did you follow? Note that
you're resolving a targlet platform which is configured to resolve all
platforms (and if I recall correctly, the release train/platform repos
had some dependencies on os/arch fragment for which there were no
provided fragment....


On 08.02.2016 20:14, Thibault Le Ouay wrote:
> Hey,
> i'm trying to set up an eclipse platform UI install on a new computer
> but I get the following error
>
> ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while
> installing the items
> at
> org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:688)
> at
> org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:974)
> at
> org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:119)
> at
> org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:910)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3036)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:2980)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4170)
> at
> org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
> at
> org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4164)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4162)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2971)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2946)
> at
> org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2857)
> at
> org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:555)
> at
> org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:674)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
> ERROR: org.eclipse.equinox.p2.engine code=0 session context
> was:(profile=C__eclipse_UI_WS-68b9fddef2d38b9b8eb69e3bdc3759af24693dda, phase=org.eclipse.oomph.targlets.internal.core.TargletContainer$TargletCommitContext$3,
> operand=null --> [R]org.eclipse.equinox.executable_root.gtk.hpux.ia64
> 3.6.300.N20160207-2000,
> action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
> ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action
> chmod failed - file
> C:\eclipse\UI\WS\.metadata\.plugins\org.eclipse.pde.core\.install_folders\1454957901198\launcher
> does not exist
>
>
> I dont get why it's looking for the gtk.hpux executable as i am on a
> windows 10 computer :(
> It looks similar to this post :
> https://www.eclipse.org/forums/index.php/t/905967/
>
> Hope you can help me.
> Thanks
>
> Thibault
Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1722795 is a reply to message #1722783] Tue, 09 February 2016 08:43 Go to previous messageGo to next message
Thibault Le Ouay is currently offline Thibault Le OuayFriend
Messages: 23
Registered: October 2014
Junior Member
I followed these steps with build 2172 :

I choose Eclipse commiters (Neon) 64 bits.
then Platform UI
I filled up the installation repository,

I follow the same step on my windows 7 x64 desktop computer but on my laptop a windows 10 x64 computer, I encounter this error.

Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1722798 is a reply to message #1722795] Tue, 09 February 2016 09:07 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31014
Registered: July 2009
Senior Member
So it works on Windows 7 but fails on Windows 10?

Given I don't have a Windows 10 box, this might be tricky to reproduce
and fix. :-( Perhaps with a virtual box, but it will be quite some
weeks before I can find time for that...


On 09.02.2016 09:43, Thibault Le Ouay wrote:
> I followed these steps with build 2172 :
>
> I choose Eclipse commiters (Neon) 64 bits. then Platform UI I filled
> up the installation repository,
> I follow the same step on my windows 7 x64 desktop computer but on my
> laptop a windows 10 x64 computer, I encounter this error.
>
Previous Topic:Oomph Defect? Build Automatically Keeps Getting Disabled
Next Topic:An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase
Goto Forum:
  


Current Time: Thu Apr 02 10:45:21 GMT 2020

Powered by FUDForum. Page generated in 0.02807 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top