Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Mac running Windows Parallels will not install Eclipse Installer or Luna downloads(An up-to-date Mac computer running Windows Parallels will not install the Eclipse Installer or Eclipse Luna files that have been downloaded)
Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721221] Mon, 25 January 2016 20:29 Go to next message
Stephen Eastmond is currently offline Stephen EastmondFriend
Messages: 2
Registered: January 2016
Junior Member
I have someone in my company who is running Windows Parallels on a Mac computer. I had her download Eclipse Luna so that we can run SuiteCloud IDE. However, when she attempted to install the Eclipse Installer, she got an error message that her Java needed to be updated. She updated Java, but still gets the same message. I had her download Eclipse Luna directly, and she gets the same message when trying to install it, as well.

The Mac is running OS X 10.9.5 and Java version 8, update 71, build 15. She is installing through the Mac environment. The error message is:

Incompatible JVM

Version 1.6.0_65 of the JVM is not suitable for this product. Version 1.7 or greater is required.


I am no expert at Mac installations, let alone Windows Parallels on a Mac, but it seems that the requirement to update Java has been met, so why does this error keep coming up?
Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721224 is a reply to message #1721221] Mon, 25 January 2016 21:20 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Please clarify: are you trying to install Eclipse for Mac (to run in OS X), or into the Parallels VM (to run in Windows)?
Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721225 is a reply to message #1721224] Mon, 25 January 2016 21:23 Go to previous messageGo to next message
Stephen Eastmond is currently offline Stephen EastmondFriend
Messages: 2
Registered: January 2016
Junior Member
We are trying to install Eclipse for Mac. If it needs to run in Windows, we would need to install the Windows version, correct?
Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721226 is a reply to message #1721225] Mon, 25 January 2016 21:26 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
That's correct.
See this answer; follow the instructions and you should get up and running.

[Updated on: Mon, 01 February 2016 15:30]

Report message to a moderator

Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721664 is a reply to message #1721221] Fri, 29 January 2016 03:15 Go to previous messageGo to next message
David Crowe is currently offline David CroweFriend
Messages: 2
Registered: January 2016
Junior Member
I also have the same problem. I've updated Java, and still get the error message:

Version 1.6.0_65 of the JVM is not suitable for this product. Version 1.7 or greater is required.

Running Java Version 8 and OS X 10.10.5
Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721723 is a reply to message #1721664] Fri, 29 January 2016 13:29 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
David Crowe wrote on Fri, 29 January 2016 03:15
I also have the same problem. I've updated Java, and still get the error message:

Version 1.6.0_65 of the JVM is not suitable for this product. Version 1.7 or greater is required.

Running Java Version 8 and OS X 10.10.5

Did you read and follow the advice in the answer I linked to above? Specifically, install the JDK (not the JRE).
Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721728 is a reply to message #1721723] Fri, 29 January 2016 14:03 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 485
Registered: August 2014
Senior Member
Please check if you want to run Eclipse in:
-a) OS X with the installed Java
-b) Windows/Parallels (without Java?)

If a): forget Parallels, just get Eclipse installer for Mac and use it to install Eclipse. If you intend to use Eclipse for Java, please install JDK instead of JRE only.

If b), you're intending to run Eclipse in Parallels/Windows, do:
- fire up Windows under Parallels, and from it:
- install newest JDK for Windows from Oracle pages,
- get Eclipse installer for Windows,
- use it to install Eclipse to Windows.



--

Tauno Voipio
Re: Mac running Windows Parallels will not install Eclipse Installer or Luna downloads [message #1721770 is a reply to message #1721728] Sat, 30 January 2016 01:32 Go to previous message
David Crowe is currently offline David CroweFriend
Messages: 2
Registered: January 2016
Junior Member
It is very difficult to see that "this answer" contains a link (it's only in boldface and easy to overlook). Eventually I found it and followed it through to this link: www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

I've put the actual link in my response so it's easier to see (and because I'm not yet allowed to post links outside eclipse.org). It was reported in 2009 that the link is changed frequently, but that doesn't appear to be the case, as the link still works as of today.
Previous Topic:Problem : "The currently displayed page contains invalid values"
Next Topic:Eclipse appends local path when launching URLs
Goto Forum:
  


Current Time: Mon Jun 17 01:35:19 GMT 2019

Powered by FUDForum. Page generated in 0.03351 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top