Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » The control "Next >" is disabled.(After I recorded a test case sucessfuly I found that an text fill doesnt not turn the next button on, but if I type a letter manually it turns out to be enabled.)
The control "Next >" is disabled. [message #1720374] Mon, 18 January 2016 09:27 Go to next message
ilke Muhtaroglu is currently offline ilke MuhtarogluFriend
Messages: 33
Registered: September 2015
Member
I have a dialog where I have to enter a name for an item, when I enter the name the next button is enabled. So during recording phase I can succesfully record entering name and press next button. But when play the test case Entering a text into the name field does not enable the next button. It does not get enabled even when I enter a different name. It gets enabled when I enter a name with keyboard, but not with the RCPTT.

What can be a solution ? What should I look at to correct it ?

ilke

P.S. At our code we have a KeyListener at this item name such like :

name.addKeyListener (new KeyAdapter() {
@Override
public void keyReleased (KeyEvent e) {
setPageComplete(validatePageInput());
}
});

Here it is listening for keyReleased. Is this the reason for this to happen ? What should I have here. The user will press a key so this works but for RCPTT is there a different necessity ?

[Updated on: Mon, 18 January 2016 11:55]

Report message to a moderator

Re: The control "Next >" is disabled. [message #1769794 is a reply to message #1720374] Thu, 03 August 2017 13:09 Go to previous message
Yvan Lussaud is currently offline Yvan LussaudFriend
Messages: 20
Registered: July 2009
Junior Member
I had the same problem with a KeyListener.keyReleased(). I added a key-type to solve the problem. In my case the key-type only seems to trigger the listener:

with [get-editbox -after [get-label "..."]] {
set-text "some text"
key-type x
}

Previous Topic:Tests with SWING components
Next Topic:AUT Connection Error
Goto Forum:
  


Current Time: Sun May 27 10:12:25 GMT 2018

Powered by FUDForum. Page generated in 0.01350 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top