Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » tycho build failing due to missing efxclipse dependencies
tycho build failing due to missing efxclipse dependencies [message #1720127] Thu, 14 January 2016 15:13 Go to next message
Ali Karimi is currently offline Ali KarimiFriend
Messages: 30
Registered: October 2015
Member
Hey,

currently i am stuck at getting a tycho build of my efxclipse e4 application up and running. I have the usual project structure and a bunch of my own plugins like this:



  1. test.app
  2. test.app.product
  3. test.app.feature
  4. test.app.releng
  5. test.app.plugin.1
  6. ...
  7. test.app.plugin.n


I have added a pom.xml file to each of those projects an the parent pom file resides in the test.app.releng project. I have adjusted the test.app.releng/pom.xml to include the other plugins by adding a corresponding entry in the modules section for each plugin.

The maven build succeeds, the deployment using the ant script in test.app.releng/build.xml also works fine and create en executable of my application. I am also able to start my application. However, i am having several exceptions with Unresolved requirements. Each of them are coming from bundles which should be provided by the target platform, at least i thought they would be.

Anyone an idea of what could be wrong??

Thanks in advance.

Here is the log:

!SESSION 2016-01-14 15:57:21.076 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_60
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE

!ENTRY test.app 4 0 2016-01-14 15:57:22.626
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: test.app [6]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.di
    -> Bundle-SymbolicName: org.eclipse.e4.ui.di; bundle-version="1.1.0.v20150422-0725"
       org.eclipse.e4.ui.di [60]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.extensions; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.di.extensions; bundle-version="0.13.0.v20150421-2214"; singleton:="true"
              org.eclipse.e4.core.di.extensions [57]
                Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY test.app.base 4 0 2016-01-14 15:57:22.628
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: test.app.base [8]
  Unresolved requirement: Import-Package: org.eclipse.fx.core.log

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY test.app.model 4 0 2016-01-14 15:57:22.628
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: test.app.model [19]
  Unresolved requirement: Import-Package: org.eclipse.fx.core.adapter; version="2.2.0"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY test.app.services 4 0 2016-01-14 15:57:22.628
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: test.app.services [23]
  Unresolved requirement: Import-Package: test.app.plugin.test3
    -> Export-Package: test.app.plugin.test3; bundle-symbolic-name="test.app.plugin.test4"; bundle-version="1.0.0.201601141456"; version="0.0.0"
       test.app.plugin.test4 [12]
         Unresolved requirement: Import-Package: org.eclipse.e4.ui.workbench.lifecycle
           -> Export-Package: org.eclipse.e4.ui.workbench.lifecycle; bundle-symbolic-name="org.eclipse.e4.ui.workbench"; bundle-version="1.3.0.v20150531-1948"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.swt"
              org.eclipse.e4.ui.workbench [63]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.services; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.ui.services; bundle-version="1.2.0.v20150422-0725"; singleton:="true"
                     org.eclipse.e4.ui.services [62]
                       Unresolved requirement: Import-Package: org.osgi.service.event; resolution:="optional"
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.di; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.ui.di; bundle-version="1.1.0.v20150422-0725"
                            org.eclipse.e4.ui.di [60]
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.extensions; bundle-version="0.9.0"
                                -> Bundle-SymbolicName: org.eclipse.e4.core.di.extensions; bundle-version="0.13.0.v20150421-2214"; singleton:="true"
                                   org.eclipse.e4.core.di.extensions [57]
                                     Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY test.app.services.remote 4 0 2016-01-14 15:57:22.630
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: test.app.services.remote [24]
  Unresolved requirement: Import-Package: test.app.services.internal.message.validator
    -> Export-Package: test.app.services.internal.message.validator; bundle-symbolic-name="test.app.services"; bundle-version="1.0.0.201601141456"; version="0.0.0"
       test.app.services [23]
         Unresolved requirement: Import-Package: test.app.plugin.test3
           -> Export-Package: test.app.plugin.test3; bundle-symbolic-name="test.app.plugin.test4"; bundle-version="1.0.0.201601141456"; version="0.0.0"
              test.app.plugin.test4 [12]
                Unresolved requirement: Import-Package: org.eclipse.e4.ui.workbench.lifecycle
                  -> Export-Package: org.eclipse.e4.ui.workbench.lifecycle; bundle-symbolic-name="org.eclipse.e4.ui.workbench"; bundle-version="1.3.0.v20150531-1948"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.swt"
                     org.eclipse.e4.ui.workbench [63]
                       Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.services; bundle-version="0.9.0"
                         -> Bundle-SymbolicName: org.eclipse.e4.ui.services; bundle-version="1.2.0.v20150422-0725"; singleton:="true"
                            org.eclipse.e4.ui.services [62]
                              Unresolved requirement: Import-Package: org.osgi.service.event; resolution:="optional"
                              Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.di; bundle-version="0.9.0"
                                -> Bundle-SymbolicName: org.eclipse.e4.ui.di; bundle-version="1.1.0.v20150422-0725"
                                   org.eclipse.e4.ui.di [60]
                                     Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.extensions; bundle-version="0.9.0"
                                       -> Bundle-SymbolicName: org.eclipse.e4.core.di.extensions; bundle-version="0.13.0.v20150421-2214"; singleton:="true"
                                          org.eclipse.e4.core.di.extensions [57]
                                            Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY test.app.plugin.test 4 0 2016-01-14 15:57:22.631
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: test.app.plugin.test [25]
  Unresolved requirement: Import-Package: test.app.plugin.test2
    -> Export-Package: test.app.plugin.test2; bundle-symbolic-name="test.app.plugin.test2"; bundle-version="1.0.0.201601141456"; version="0.0.0"
       test.app.plugin.test2 [10]
         Unresolved requirement: Import-Package: test.app.model.property
           -> Export-Package: test.app.model.property; bundle-symbolic-name="test.app.model"; bundle-version="1.0.0.201601141456"; version="0.0.0"
              test.app.model [19]
                Unresolved requirement: Import-Package: org.eclipse.fx.core.adapter; version="2.2.0"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.core.di.extensions 4 0 2016-01-14 15:57:22.633
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.core.di.extensions [57]
  Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.di 4 0 2016-01-14 15:57:22.633
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.di [60]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.extensions; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.e4.core.di.extensions; bundle-version="0.13.0.v20150421-2214"; singleton:="true"
       org.eclipse.e4.core.di.extensions [57]
         Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.services 4 0 2016-01-14 15:57:22.635
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.services [62]
  Unresolved requirement: Import-Package: org.osgi.service.event; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.di; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.di; bundle-version="1.1.0.v20150422-0725"
       org.eclipse.e4.ui.di [60]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.extensions; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.di.extensions; bundle-version="0.13.0.v20150421-2214"; singleton:="true"
              org.eclipse.e4.core.di.extensions [57]
                Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.e4.ui.workbench 4 0 2016-01-14 15:57:22.636
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench [63]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.services; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.services; bundle-version="1.2.0.v20150422-0725"; singleton:="true"
       org.eclipse.e4.ui.services [62]
         Unresolved requirement: Import-Package: org.osgi.service.event; resolution:="optional"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.di; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.di; bundle-version="1.1.0.v20150422-0725"
              org.eclipse.e4.ui.di [60]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.extensions; bundle-version="0.9.0"
                  -> Bundle-SymbolicName: org.eclipse.e4.core.di.extensions; bundle-version="0.13.0.v20150421-2214"; singleton:="true"
                     org.eclipse.e4.core.di.extensions [57]
                       Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.http.jetty 4 0 2016-01-14 15:57:22.638
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.http.jetty [72]
  Unresolved requirement: Import-Package: org.eclipse.equinox.http.servlet; version="1.0.0"
    -> Export-Package: org.eclipse.equinox.http.servlet; bundle-symbolic-name="org.eclipse.equinox.http.servlet"; bundle-version="1.2.1.v20150828-1818"; version="1.1.0"
       org.eclipse.equinox.http.servlet [74]
         Unresolved requirement: Import-Package: org.osgi.service.http; version="[1.2.0,1.3.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.http.servlet 4 0 2016-01-14 15:57:22.638
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.http.servlet [74]
  Unresolved requirement: Import-Package: org.osgi.service.http; version="[1.2.0,1.3.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.ds 4 0 2016-01-14 15:57:22.775
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.ds [80]
  Unresolved requirement: Import-Package: org.eclipse.equinox.internal.util.event; version="1.0.0"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.event 4 0 2016-01-14 15:57:22.775
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.event [81]
  Unresolved requirement: Import-Package: org.osgi.service.event; version="[1.3.0,1.4.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.ds 1 0 2016-01-14 15:57:23.285
!MESSAGE Could not bind a reference of component org.eclipse.fx.core.log4j.Log4JLoggerFactory. The reference is: Reference[name = registerAppender, interface = org.apache.log4j.Appender, policy = dynamic, policy-option = greedy, cardinality = 0..n, target = null, bind = registerAppender, unbind = unregisterAppender, updated = null]

!ENTRY org.eclipse.equinox.ds 1 0 2016-01-14 15:57:23.287
!MESSAGE Could not bind a reference of component org.eclipse.fx.core.internal.JUtilLoggerFactory. The reference is: Reference[name = registerHandler, interface = java.util.logging.Handler, policy = dynamic, policy-option = greedy, cardinality = 0..n, target = null, bind = registerHandler, unbind = unregisterHandler, updated = null]

!ENTRY org.eclipse.equinox.ds 1 0 2016-01-14 15:57:24.280
!MESSAGE Could not bind a reference of component test.app.themes.default. The reference is: Reference[name = Stylesheet, interface = org.eclipse.fx.ui.services.theme.Stylesheet, policy = dynamic, cardinality = 0..n, target = null, bind = registerStylesheet, unbind = unregisterStylesheet]

Re: tycho build failing due to missing efxclipse dependencies [message #1720130 is a reply to message #1720127] Thu, 14 January 2016 15:40 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6412
Registered: July 2009
Senior Member
Please show us your app.feature

Tom
Re: tycho build failing due to missing efxclipse dependencies [message #1720135 is a reply to message #1720130] Thu, 14 January 2016 16:06 Go to previous messageGo to next message
Ali Karimi is currently offline Ali KarimiFriend
Messages: 30
Registered: October 2015
Member
Thanks for the fast answer:

here it is:
<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="test.app.feature"
      label="test Application Feature"
      version="1.0.0.qualifier"
      provider-name="My comp">

   <description url="[url]http://www.efxclipse.org[/url]">
      TODO FILL WITH CONTENT
   </description>

   <copyright url="[url]http://www.efxclipse.org[/url]">
      TODO FILL WITH CONTENT
   </copyright>

   <license url="[url]http://www.efxclipse.org[/url]">
      TODO FILL WITH CONTENT
   </license>

   <plugin
         id="org.eclipse.fx.core.log4j"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="org.eclipse.fx.core"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.base"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.model"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.services"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.log4j.properties"
         download-size="0"
         install-size="0"
         version="0.0.0"
         fragment="true"
         unpack="false"/>

   <plugin
         id="test.app"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.plugin.test"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.plugin.test2"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>
		 
   <plugin
         id="test.app.plugin.test3"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.plugin.test4"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.services.remote"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

   <plugin
         id="test.app.services.local"
         download-size="0"
         install-size="0"
         version="0.0.0"
         unpack="false"/>

</feature>

[Updated on: Thu, 14 January 2016 16:12]

Report message to a moderator

Re: tycho build failing due to missing efxclipse dependencies [message #1720152 is a reply to message #1720135] Thu, 14 January 2016 18:34 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6412
Registered: July 2009
Senior Member
Hi,

Who created this feature? It misses the e4 rcp feature!

Tom

On 14.01.16 17:06, Ali Karimi wrote:
> Thanks for the fast answer:
>
> here it is, please bare with me.
> Quote:
>> <?xml version="1.0" encoding="UTF-8"?>
>> <feature
>> id="test.app.feature"
>> label="test Application Feature"
>> version="1.0.0.qualifier"
>> provider-name="My comp">
>>
>> <description url="http://www.efxclipse.org">
>> TODO FILL WITH CONTENT
>> </description>
>>
>> <copyright url="http://www.efxclipse.org">
>> TODO FILL WITH CONTENT
>> </copyright>
>>
>> <license url="http://www.efxclipse.org">
>> TODO FILL WITH CONTENT
>> </license>
>>
>> <plugin
>> id="org.eclipse.fx.core.log4j"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="org.eclipse.fx.core"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.base"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.model"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.services"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.log4j.properties"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> fragment="true"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.plugin.test"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.plugin.test2"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>> <plugin
>> id="test.app.plugin.test3"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.plugin.test4"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.services.remote"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> <plugin
>> id="test.app.services.local"
>> download-size="0"
>> install-size="0"
>> version="0.0.0"
>> unpack="false"/>
>>
>> </feature>
>
>
Re: tycho build failing due to missing efxclipse dependencies [message #1720192 is a reply to message #1720152] Fri, 15 January 2016 07:26 Go to previous messageGo to next message
Ali Karimi is currently offline Ali KarimiFriend
Messages: 30
Registered: October 2015
Member
Hey,

it was automatically created by the eclipse tooling. Of course, i have modified it by adding my plugins.
I just tested it again by creating a new application (e.g. in eclipse new -> JavaFX -> OSGI -> e4 Application projects ) and it creates the standard 4 projects (NAME.app, NAME.app.feature, NAME.app.product, NAME.app.releng).
Looking into the brand new generated feature.xml there is nothing added like your mentioned e4 rcp feature. The only plugin that is listed there is the NAME.app plugin.

Which feature are you talking about exactly? And how can the application run when started from eclipse if this feature is missing as it seems to be rather mandatory?
Re: tycho build failing due to missing efxclipse dependencies [message #1720196 is a reply to message #1720192] Fri, 15 January 2016 07:49 Go to previous messageGo to next message
Ali Karimi is currently offline Ali KarimiFriend
Messages: 30
Registered: October 2015
Member
Please note, i tried to add the org.eclipse.e4.rcp feature to my feature.xm. For this i had to adjust my NAME.app.releng/pom.xml
file by adding a new repository, the one from eclipse (e.g. http://download.eclipse.org/eclipse/updates/4.5) .
However, still no luck. Build/deployment completes normally, starting the application still gives several Unresolved requirements exceptions.

Any help would be greatly apprechiated.

[Updated on: Fri, 15 January 2016 07:49]

Report message to a moderator

Re: tycho build failing due to missing efxclipse dependencies [message #1720199 is a reply to message #1720196] Fri, 15 January 2016 08:15 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6412
Registered: July 2009
Senior Member
Oh yeah your are right may bad!

What's the content of your .product?

It should be made up of:
- your.app.feature
- org.eclipse.fx.runtime.e4fx.feature who includes the complete runtime
dependencies (eg org.eclipse.osgi.services which is the root-cause of
all your troubles)


Tom

On 15.01.16 08:49, Ali Karimi wrote:
> Please note, i tried to add the org.eclipse.e4.rcp feature to my
> feature.xm. For this i had to adjust my NAME.app.releng/pom.xml file by
> adding a new repository, the one from eclipse (e.g.
> http://download.eclipse.org/eclipse/updates/4.5) .
> However, still no luck. Build/deployment completes normally, starting
> the application still gives several Unresolved requirements exceptions.
Re: tycho build failing due to missing efxclipse dependencies [message #1720200 is a reply to message #1720196] Fri, 15 January 2016 08:16 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6412
Registered: July 2009
Senior Member
Oh and don't add http://download.eclipse.org/eclipse/updates/4.5 this
will make things fail totally. The e4.rcp-Feature btw is bound to SWT!

Tom

On 15.01.16 08:49, Ali Karimi wrote:
> Please note, i tried to add the org.eclipse.e4.rcp feature to my
> feature.xm. For this i had to adjust my NAME.app.releng/pom.xml file by
> adding a new repository, the one from eclipse (e.g.
> http://download.eclipse.org/eclipse/updates/4.5) .
> However, still no luck. Build/deployment completes normally, starting
> the application still gives several Unresolved requirements exceptions.
Re: tycho build failing due to missing efxclipse dependencies [message #1720201 is a reply to message #1720200] Fri, 15 January 2016 08:32 Go to previous messageGo to next message
Ali Karimi is currently offline Ali KarimiFriend
Messages: 30
Registered: October 2015
Member
Yes, i tired to add this repository just in case i completely missunderstood something.

Here is the contents of product file:
<?xml version="1.0" encoding="UTF-8"?>
<?pde version="3.5"?>

<product name="test.app" uid="test.app.app.product" id="tes.app.product" application="org.eclipse.fx.ui.workbench.fx.application" version="1.0.0" useFeatures="true" includeLaunchers="false">

   <configIni use="default">
   </configIni>

   <launcherArgs>
      <programArgs>-nosplash -clear -clearPersistedState -consoleLog
      </programArgs>
      <vmArgs>-Dorg.osgi.framework.bundle.parent=ext -Dorg.eclipse.equinox.http.jetty.http.port=8888
      </vmArgs>
   </launcherArgs>

   <windowImages/>

   <launcher>
      <solaris/>
      <win useIco="false">
         <bmp/>
      </win>
   </launcher>

   <vm>
   </vm>

   <plugins>
   </plugins>

   <features>
      <feature id="test.app.app.feature"/>
      <feature id="org.eclipse.fx.runtime.e4fx.feature"/>
   </features>

   <configurations>
      <plugin id="org.eclipse.core.runtime" autoStart="true" startLevel="0" />
      <plugin id="org.eclipse.equinox.common" autoStart="true" startLevel="2" />
      <plugin id="org.eclipse.equinox.ds" autoStart="true" startLevel="0" />
      <plugin id="org.eclipse.equinox.event" autoStart="true" startLevel="0" />
      <plugin id="org.eclipse.equinox.simpleconfigurator" autoStart="true" startLevel="0" />
      <plugin id="org.eclipse.osgi" autoStart="true" startLevel="0" />
   </configurations>

   <preferencesInfo>
      <targetfile overwrite="false"/>
   </preferencesInfo>

   <cssInfo>
   </cssInfo>

</product>


Please note one thing i noticed is, the Exception in my log complains about Unresolved requirement: Require-Bundle: org.eclipse.osgi.services; bundle-version="3.2.100".
In the plugins directory of my deployed application i can only find org.eclipse.osgi.services_3.5.0.v20150519-2006.jar. I guess there is a version missmatch, isnt there?
This is true for some other plugins too. However, i have no clue why?
Re: tycho build failing due to missing efxclipse dependencies [message #1720203 is a reply to message #1720201] Fri, 15 January 2016 08:39 Go to previous message
Ali Karimi is currently offline Ali KarimiFriend
Messages: 30
Registered: October 2015
Member
Okay, it seems i found the root cause. For some reason the startlevel of my org.eclipse.osgi entry in the product file is 0, as it must be -1.
No more Unresolved requirements exceptions. Thanks in advance.
Previous Topic:Code editor repo
Next Topic:Min/Max Bug
Goto Forum:
  


Current Time: Sun Sep 23 02:09:51 GMT 2018

Powered by FUDForum. Page generated in 0.03070 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top