Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » org.eclipse.fx.javafx cannot be resolved
org.eclipse.fx.javafx cannot be resolved [message #1719693] Mon, 11 January 2016 13:49 Go to next message
Jörg Wille is currently offline Jörg WilleFriend
Messages: 11
Registered: December 2011
Junior Member
I am new to e(fx)clipse and have not much experience with eclipse/osgi!
I want a simple osgi javafx application (no e4)

I have installed e(fx)clipse like explained here:
https://wiki.eclipse.org/Efxclipse/Tutorials/AddingE(fx)clipse_to_eclipse
Only using e(fx)clipse - IDE 2.2.0.201512111004 org.eclipse.fx.ide.feature.feature.group Eclipse.org

I also have created new target def by adding "Target Platform Feature" from http://download.eclipse.org/efxclipse/runtime-released/2.2.0/site/

Then I created a new "OSGi Application Project" and only checked "Tycho Build Stubs".

Right when the wizard is finished I see many errors in MAINIFEST.MF.
org.eclipse.fx.javafx from required bundle cannot be resolved
and there are no available bundle exports for all javafx.* packages.

I tried to solve this by adding:
-Dorg.osgi.framework.bundle.parent=ext
to target def VM arguments.
But this does not help.

What am I doing wrong?
Re: org.eclipse.fx.javafx cannot be resolved [message #1719694 is a reply to message #1719693] Mon, 11 January 2016 14:01 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph KeimelFriend
Messages: 480
Registered: December 2010
Location: Germany
Senior Member
It seems that the wizard is outdated as it creates sources for efxclipse 1.x and not 2.2.

To fix this you need to change the MANIFEST.MF:
- Remove all javafx.* imports from the imported packages
- Remove org.eclipse.fx.javafx from the required bundles

And you need to change the product configuration:
- Replace "-Dosgi.framework.extensions=org.eclipse.fx.osgi" with "-Dorg.osgi.framework.bundle.parent=ext"

Hope this helps!
Re: org.eclipse.fx.javafx cannot be resolved [message #1719696 is a reply to message #1719694] Mon, 11 January 2016 14:07 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph KeimelFriend
Messages: 480
Registered: December 2010
Location: Germany
Senior Member
I created Bug 485552 for this.
Re: org.eclipse.fx.javafx cannot be resolved [message #1719697 is a reply to message #1719694] Mon, 11 January 2016 14:32 Go to previous message
Jörg Wille is currently offline Jörg WilleFriend
Messages: 11
Registered: December 2011
Junior Member
I did add:
-Dorg.osgi.framework.bundle.parent=ext
to product configuration "launching" as "VM Arguments".

But it only worked when I added it to the Run Configuration of the Eclipse Application.

So far so good. Thanks!

[Updated on: Mon, 11 January 2016 20:47]

Report message to a moderator

Previous Topic:Editor's tabs header is not fully visible
Next Topic:Code editor repo
Goto Forum:
  


Current Time: Wed Sep 19 13:23:33 GMT 2018

Powered by FUDForum. Page generated in 0.01853 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top