Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » R5 repo requirement indexing - osgi.ds(requirement (osgi.extender=osgi.ds) should be (osgi.extender=osgi.component)?)
R5 repo requirement indexing - osgi.ds [message #1717776] Wed, 16 December 2015 16:12 Go to next message
Elias Vasylenko is currently offline Elias VasylenkoFriend
Messages: 19
Registered: December 2015
Junior Member
Hey guys, just wondering what the official position is on the R5 repository regarding the whole (osgi.extender=osgi.ds) to (osgi.extender=osgi.component) migration issue.

I'm not an expert, but afaiu the current OSGi spec says "osgi.component" is appropriate, but the e(fx)clipse R5 repo contains requirements on the provisional "osgi.ds" instead.

Previously I was downloading the p2 repo myself and reindexing as R5 with bndtools 3.1.0 (as I hadn't realised there was one already hosted). This was working fine, but when I try to use the official index directly I suddenly have requirement resolution errors, which appear to be caused by this "osgi.ds" requirement.

Any chance you would consider updating, at least by the 2.3.0 release?

Cheers,

Eli
Re: R5 repo requirement indexing - osgi.ds [message #1717796 is a reply to message #1717776] Wed, 16 December 2015 18:53 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6410
Registered: July 2009
Senior Member
Sure file a bug - we are using
https://github.com/BestSolution-at/bindex-maven-plugin so most likely
this needs to be updated?

Tom

On 16.12.15 17:12, Elias Vasylenko wrote:
> Hey guys, just wondering what the official position is on the R5
> repository regarding the whole (osgi.extender=osgi.ds) to
> (osgi.extender=osgi.component) migration issue.
>
> I'm not an expert, but afaiu the current OSGi spec says "osgi.component"
> is appropriate, but the e(fx)clipse R5 repo contains requirements on the
> provisional "osgi.ds" instead.
>
> Previously I was downloading the p2 repo myself and reindexing as R5
> with bndtools 3.1.0 (as I hadn't realised there was one already hosted).
> This was working fine, but when I try to use the official index directly
> I suddenly have requirement resolution errors, which appear to be caused
> by this "osgi.ds" requirement.
>
> Any chance you would consider updating, at least by the 2.3.0 release?
>
> Cheers,
>
> Eli
Re: R5 repo requirement indexing - osgi.ds [message #1717843 is a reply to message #1717796] Thu, 17 December 2015 09:56 Go to previous message
Elias Vasylenko is currently offline Elias VasylenkoFriend
Messages: 19
Registered: December 2015
Junior Member
Thanks, looks like bindex-maven-plugin issue as you say. I've filed a bug with a little more information here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=484549

Thanks for the pointer!
Previous Topic:How to use EMenuService to register ContexMenu on Circle
Next Topic:building e4+javafx application with tycho
Goto Forum:
  


Current Time: Wed Sep 19 08:51:49 GMT 2018

Powered by FUDForum. Page generated in 0.01786 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top