Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » [buckminster-dev] adding build plugin to headless eclipse (2)
[buckminster-dev] adding build plugin to headless eclipse (2) [message #1717639] Tue, 15 December 2015 13:54 Go to next message
Dieter Cailliau is currently offline Dieter CailliauFriend
Messages: 10
Registered: July 2009
Junior Member
I guess the problem is that this DS annotation builder is simply not
headless, as it depends on eclipse.ui. Can i work arround this? Can i
install the whole eclipse.iu into headless buckminster?

../director -r $urlwuetherich -d $dest -p Buckminster -i
com.wuetherich.osgi.ds.annotations.feature.feature.group
Installing com.wuetherich.osgi.ds.annotations.feature.feature.group
1.1.5.201411080545.
Installation failed.
Cannot complete the install because one or more required items could
not be found.
Software being installed: com.wuetherich.osgi.ds.annotations.feature
1.1.5.201411080545
(com.wuetherich.osgi.ds.annotations.feature.feature.group
1.1.5.201411080545)
Missing requirement: com.wuetherich.osgi.ds.annotations.feature
1.1.5.201411080545
(com.wuetherich.osgi.ds.annotations.feature.feature.group
1.1.5.201411080545) requires 'org.eclipse.ui 3.6.0' but it could not
be found
Application failed, log file location:
/tmp/9973/director/configuration/1450187608918.log
Re: [buckminster-dev] adding build plugin to headless eclipse (2) [message #1718382 is a reply to message #1717639] Wed, 23 December 2015 08:09 Go to previous message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1751
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 15/12/2015 14:54, Dieter Cailliau wrote:
> I guess the problem is that this DS annotation builder is simply not
> headless, as it depends on eclipse.ui. Can i work arround this? Can i
> install the whole eclipse.iu into headless buckminster?
>
> ./director -r $urlwuetherich -d $dest -p Buckminster -i
> com.wuetherich.osgi.ds.annotations.feature.feature.group
> Installing com.wuetherich.osgi.ds.annotations.feature.feature.group
> 1.1.5.201411080545.
> Installation failed.
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: com.wuetherich.osgi.ds.annotations.feature
> 1.1.5.201411080545
> (com.wuetherich.osgi.ds.annotations.feature.feature.group
> 1.1.5.201411080545)
> Missing requirement: com.wuetherich.osgi.ds.annotations.feature
> 1.1.5.201411080545
> (com.wuetherich.osgi.ds.annotations.feature.feature.group
> 1.1.5.201411080545) requires 'org.eclipse.ui 3.6.0' but it could not
> be found
> Application failed, log file location:
> /tmp/9973/director/configuration/1450187608918.log
>

Hi

I tried something similar in the past in order to install the Xtend
builder in buckminster. Also in that case that builder depends on UI,
so I had to give up: even if you install eclipse.ui features in
buckminster you'll get errors about missing Display...

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Previous Topic:[buckminster-dev] adding build plugin to headless eclipse
Next Topic:[buckminster-dev] signing problem
Goto Forum:
  


Current Time: Tue Sep 25 14:34:01 GMT 2018

Powered by FUDForum. Page generated in 0.01884 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top