Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Using New Installer on Mac(Incompatible JVM Problem)
Using New Installer on Mac [message #1717586] Tue, 15 December 2015 05:29 Go to next message
David Akins is currently offline David AkinsFriend
Messages: 1
Registered: December 2015
Junior Member
In trying to use the Eclipse Installer on a Powerbook Pro running OS X 10.11.1,
I get the message "Incompatible JVM" with details: "Version 1.6.0_65 of JVM not suitable, 1.7 or greater rerquired".

Any suggestions on how the issue can be resolved would be appreciated. Thanks.
Re: Using New Installer on Mac [message #1717665 is a reply to message #1717586] Tue, 15 December 2015 15:42 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 12/15/2015 07:51 AM, David Akins wrote:
> In trying to use the Eclipse Installer on a Powerbook Pro running OS X
> 10.11.1,
> I get the message "Incompatible JVM" with details: "Version 1.6.0_65 of
> JVM not suitable, 1.7 or greater rerquired".
>
> Any suggestions on how the issue can be resolved would be appreciated.
> Thanks.
Not a Macintosh guy, but wouldn't this just mean it's time to bump your
JRE to a modern one? The current Oracle JRE is at 1.8. 1.6 and 1.7
aren't really supported anymore. (Apple may be different on this point,
I don't know.)
Re: Using New Installer on Mac [message #1717765 is a reply to message #1717665] Wed, 16 December 2015 15:15 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
David,
Did OS X prompt you to install "legacy" Java (1.6) when you tried to run the Eclipse installer the first time? I've seen several reports of that here and on Stack Overflow and I wonder if the Installer/Oomh team are aware of the problem.
Re: Using New Installer on Mac [message #1717787 is a reply to message #1717586] Wed, 16 December 2015 17:02 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 484
Registered: August 2014
Senior Member
David,

google for 'oracle java os x', go to the Oracle download page so found (the page address is built on the fly, so I don't give a direct link).

Select Java SE SDK 8u66 for OS X and install it from the downloaded .dmg following the Oracle instructions (nothing fancy, just a normal dmg install), and try the Mars installer again.

It works here on OS X 10.9.5 without any problems.


--

Tauno Voipio
Re: Using New Installer on Mac [message #1717837 is a reply to message #1717765] Thu, 17 December 2015 08:54 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6433
Registered: July 2009
Senior Member
Am 16.12.2015 um 16:15 schrieb Eric Rizzo:
> David,
> Did OS X prompt you to install "legacy" Java (1.6) when you tried to run the Eclipse installer the first time? I've
> seen several reports of that here and on Stack Overflow and I wonder if the Installer/Oomh team are aware of the problem.
Only for Windows we provide a special native executable that can do better than the Platform's launcher when it comes to
JVM detection and validation. We'd like to provide these enhancements for the other OSs, too, but that is quite some
effort and it's currently not high on our list of things to do. We track it here:

477998: Installer artifact for MacOS should be a .dmg or .app instead of .tar.gz
https://bugs.eclipse.org/bugs/show_bug.cgi?id=477998

Meanwhile Mac and Linux users will experience the same problems as they would when starting an Eclipse IDE directly.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: Using New Installer on Mac [message #1717871 is a reply to message #1717837] Thu, 17 December 2015 13:27 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Eike,
Are you aware that on recent versions of OS X the Oomph installer doesn't work if the user doesn't already have a JDK (not JRE) installed? They get the "legacy Java" message from OS X, but if they install that (it's Java 1.6) then the Oomph installer will run but complain that they require Java 1.7. It's a frustrating dead-end for users.
Seems like it would be worthwhile to investigate why OS X insists that the Oomph executable requires "legacy Java."

[Updated on: Thu, 17 December 2015 13:28]

Report message to a moderator

Re: Using New Installer on Mac [message #1717886 is a reply to message #1717871] Thu, 17 December 2015 14:02 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30207
Registered: July 2009
Senior Member
Eric,

Eike and I are both Windows users though we have virtual boxes for Mac
and Linux (Ubuntu). My Mac virtual box is unfortunately broken again.
So it's hard for us to experience the behavior of recent versions of OS
X. One has to wonder why a recent version of OS X doesn't come with a
decently recent version of Java, but that's hardly something any of us
can influence...

In any case, the behavior of the Eclipse native launcher on all the
platforms is arguably poor when the necessary version of Java of the
correct bitness isn't available. So on Windows we provide our own
native executable for launching the installer, which does a proper job
of figuring out which JVMs are available (even if they aren't on the
PATH), and properly prompts the user to install an appropriate JRE/JDK
when necessary. If we distributed the installer on Mac as a DMG and
provided a similar native executable with similar behavior to Windows,
we could definitely improve this situation. Failing that, we're stuck
with an ugly tar file and stuck with the Eclipse native launcher, along
with its associated nasty misbehavior. We're very sorry for that, but
the weeks of effort involved in improving this, working on a horrible
virtual box, is just not something we can manage...


On 17/12/2015 2:27 PM, Eric Rizzo wrote:
> Eike,
> Are you aware that on recent versions of OS X the Oomph installer
> doesn't work if the user doesn't already have a JDK (not JRE)
> installed? They get the "legacy Java" message from OS X, but if they
> install that (it's Java 1.6) then the Oomph installer will run but
> complain that they require Java 1.7. It's a frustrating dead-end for
> users.
Re: Using New Installer on Mac [message #1717903 is a reply to message #1717871] Thu, 17 December 2015 16:04 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6433
Registered: July 2009
Senior Member
Am 17.12.2015 um 14:27 schrieb Eric Rizzo:
> Eike,
> Are you aware that on recent versions of OS X the Oomph installer doesn't work if the user doesn't already have a JDK
> (not JRE) installed? They get the "legacy Java" message from OS X, but if they install that (it's Java 1.6) then the
> Oomph installer will run but complain that they require Java 1.7. It's a frustrating dead-end for users.
No, I wasn't aware of this "legacy Java" message from OS X. I wonder what would happen on those systems if the user
didn't use the installer but jutst unzipped a Mars package that requires Java 1.7?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: Using New Installer on Mac [message #1717907 is a reply to message #1717903] Thu, 17 December 2015 16:26 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Eike Stepper wrote on Thu, 17 December 2015 16:04
Am 17.12.2015 um 14:27 schrieb Eric Rizzo:
> Eike,
> Are you aware that on recent versions of OS X the Oomph installer doesn't work if the user doesn't already have a JDK
> (not JRE) installed? They get the "legacy Java" message from OS X, but if they install that (it's Java 1.6) then the
> Oomph installer will run but complain that they require Java 1.7. It's a frustrating dead-end for users.

No, I wasn't aware of this "legacy Java" message from OS X. I wonder what would happen on those systems if the user
didn't use the installer but jutst unzipped a Mars package that requires Java 1.7?

I bet it does the same, based on some reports from StackOverflow:
http://stackoverflow.com/a/19594116/639520
http://stackoverflow.com/q/26721749/639520
http://stackoverflow.com/q/26847411/639520

I don't have the newest versions of OS X on my MacBook so I can't verify myself, but there are quite a few reports of this on both SO and the Eclipse forums.
Re: Using New Installer on Mac [message #1718064 is a reply to message #1717586] Fri, 18 December 2015 20:26 Go to previous messageGo to next message
Jim Chaffin is currently offline Jim ChaffinFriend
Messages: 1
Registered: December 2015
Junior Member
I'm so inexperienced that I haven't reached the noobi rank yet! But I also experienced the same "legacy" dialog yesterday attempting to install/run Eclipse/Mars.1 (OS X 10.10 with Java 8[?] already installed). I finally managed to get things to run by downloading " Java SE Development Kit 7u79" from here: oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html [sorry, can't make this a link yet, this is my first message]You will have to click the "Agree" to the license radio button first, BTW.

Hope that help you, David]. But I also wish the rest of the install/usage were as easy. Rolling Eyes
Re: Using New Installer on Mac [message #1718077 is a reply to message #1717907] Sat, 19 December 2015 03:04 Go to previous message
Lizzy Alvez is currently offline Lizzy AlvezFriend
Messages: 1
Registered: December 2015
Junior Member
Were the suggestions really worked? I want to try them. Thanks.
Previous Topic:Java mewbe/student - ms sql connectionstring login failed for user
Next Topic:Coming in COLD
Goto Forum:
  


Current Time: Wed Jun 19 07:02:02 GMT 2019

Powered by FUDForum. Page generated in 0.04355 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top