Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » SysML nightly updates fail
SysML nightly updates fail [message #1717547] Mon, 14 December 2015 16:26 Go to next message
Stephen Blackwell is currently offline Stephen BlackwellFriend
Messages: 138
Registered: March 2014
Senior Member
I'm using
https://hudson.eclipse.org/papyrus/view/Sysml/job/papyrus-sysml-mars/ws/releng/org.eclipse.papyrus/sysml14.p2/target/repository
for the Sysml nightly updates and since Friday I'm getting this error when doing a Help->Check For Updates:

Will this resolve itself in a couple of days?
Steve

Cannot complete the install because of a conflicting dependency.
Software being installed: Papyrus Sysml 1.4 Feature (Incubation) 0.8.1.201512111611 (org.eclipse.paprrus.sysml14.feature.feature.group 0.8.1.201512111611)
Software currently installed: Papyrus Sysml 1.4 Feature (Incubation) Developer Resources 0.8.0.201512071408 (org.eclipse.papyrus.sysml1.4.feature.source.feature.group 0.8.0.201512071408)
Only one of the following can be installed at once:
org.eclipse.papyrus.sysml14.ui 0.8.1.201512111611 (org.eclipse.papyrus.sysml14.ui 0.8.1.201512111611)
org.eclipse.papyrus.sysml14.ui 0.8.0 201512071408 (org.eclipse.papyrus.sysml14.ui 0.8.0.201512071408)
Cannot satisfy dependency:
From: Papyrus Sysml 1.4 Feature (Incubation) 0.8.0.201512071408 (org.eclipse.papyrus.sysml14.feature.feature.group 0.8.0.201512071408)
To: org.eclipse.papyrus.sysml14.ui (0.8.0.201512071408)
Cannot satisfy dependency:
From: Papyrus Sysml 1.4 Feature (Incubation) 0.8.1.201512111611 (org.eclipse.papyrus.sysml14.feature.feature.group 0.8.1.201512111611)
To: org.eclipse.papyrus.sysml14.ui (0.8.1.201512111611)
Cannot satisfy dependency:
From: Papyrus Sysml 1.4 Feature (Incubation) Developer Resources 0.8.0.201512071408 (org.eclipse.papyrus.sysml14.feature.source.feature.group 0.8.0.201512071408)
To: org.eclipse.papyrus.sysml14.feature.feature.group (0.8.0.201512071408)
Re: SysML nightly updates fail [message #1717563 is a reply to message #1717547] Mon, 14 December 2015 20:11 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi Stephen,

Quote:
Will this resolve itself in a couple of days?


Maybe, but I wouldn't count on it. It seems that you are trying to update the SysML 1.4 binaries to 0.8.1, but not the sources (Still at version 0.8.0), which depend on a specific version of the binaries (i.e. 0.8.0)

In other words, SysML 1.4 binaries v0.8.1 are not compatible with SysML 1.4 sources v0.8.0

Using "check for updates" should update both the binaries and the sources at the same time. So unless the SysML sources have disappeared (In which case they should "come back" when a developer solves the bug), you'll have to either:

- Ensure that you update both the binaries and the sources in a consistent way
- Uninstall the sources then check for updates

(I don't have access to the update site right now, so i can't be more precise about the exact source of the issue)

HTH,
Camille


Camille Letavernier
Re: SysML nightly updates fail [message #1717671 is a reply to message #1717563] Tue, 15 December 2015 16:16 Go to previous message
Stephen Blackwell is currently offline Stephen BlackwellFriend
Messages: 138
Registered: March 2014
Senior Member
So my installed software shows a
Papyrus Sysml 1.4 Feature (Incubation), version 0.8.0.201512071408
and a
Papyrus Sysml 1.4 Feature (Incubation) Developer Resources, version 0.8.0.201512071408
which has a sub element with the same name and version as the first one.

I'm guessing that "Developer Resources" is the source code you are talking about so I deleted, re-started Eclipse, re-ran Check for Updates and now we are good.

As a side note, running Check For Updates keeps adding a new software site:
https://hudson.eclipse.org/papyrus/view/Sysml/job/papyrus-sysml-website/ws/site-staging/index.html
and then complains that there is no repo at that site. I've deleted it a couple of time but it comes right back.

Steve
Previous Topic:SysML Block compartments.
Next Topic:UML Profiles Constraints
Goto Forum:
  


Current Time: Sat Jul 11 05:23:38 GMT 2020

Powered by FUDForum. Page generated in 0.04356 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top