Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Cross model references
[CDO] Cross model references [message #1716178] Wed, 02 December 2015 00:21 Go to next message
Maged Elaasar is currently offline Maged ElaasarFriend
Messages: 23
Registered: September 2013
Junior Member
I cannot find a way to add a cross model reference in the CDO editor.

Using Eclipse Mars, I checked out a project that has two models from a local CDO repository using the offline mode. The project showed in project explorer. I then opened the CDO editor on one model and tried to load the other model in the same editor using "Load Resource..." action. In there, I selected the "Browse workspace" button, but I did not find the checked out project in the selections. I also noticed the "Import Roots" action in the CDO editor, but it is always greyed out for me.

How is this supposed to work?

Maged
Re: [CDO] Cross model references [message #1716206 is a reply to message #1716178] Wed, 02 December 2015 08:38 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6580
Registered: July 2009
Senior Member
Am 02.12.2015 um 01:21 schrieb Maged Elaasar:
> I cannot find a way to add a cross model reference in the CDO editor.
>
> Using Eclipse Mars, I checked out a project that has two models from a local CDO repository using the offline mode.
> The project showed in project explorer. I then opened the CDO editor on one model and tried to load the other model in
> the same editor using "Load Resource..." action. In there, I selected the "Browse workspace" button, but I did not
> find the checked out project in the selections.
That's the expected behavior. Please note that your offline checkout looks like a regular workspace project, but it is
not. All CDO checkouts (whether online or offline) are "just" visually integrated into the Project Explorer view, but
their models generally live in databases. Offline checkouts are based on local databases and online checkouts are based
on remote databases.

The CDO editor should always "see" all models/resources in a repository (=checkout) without the need to import resources
explicitely. Does that not work for you?


> I also noticed the "Import Roots" action in the CDO editor, but it is always greyed out for me. How is this supposed
> to work?
That action is only enabled if the selection is a CDOResource. If enabled it can load other resources and *add* their
root objects to the selected CDOResource.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: [CDO] Cross model references [message #1716335 is a reply to message #1716206] Thu, 03 December 2015 05:28 Go to previous messageGo to next message
Maged Elaasar is currently offline Maged ElaasarFriend
Messages: 23
Registered: September 2013
Junior Member
Thanks Eike. I see how it works now. Cheers.
Re: [CDO] Cross model references [message #1742587 is a reply to message #1716335] Mon, 05 September 2016 14:54 Go to previous message
Romain Bernard is currently offline Romain BernardFriend
Messages: 27
Registered: July 2009
Junior Member
Hi CDO Team,

First, thank you for providing CDO... It is a terrific framework, and I'm using it extensively !

I 'reopen' this thread, since I have the same behaviour (conf. neon & CDO 4.5) : EObjects from other resources in a repository are not presented as candidates for linking. Only EObjects owned by the current edited resource are proposed...

I tried 3 editors (CDOEditor, ECPEditor and a custom one...), they all behave the same way...

I did not find in the source code of cdo where these 'other-resources-eobjects-candidates' are taken into account (looked around CDOItemProvider and CDOItemDescriptor...).

Where should I put a breakpoint to see why other resources are not considered by the CDOEditor ?

Kind regards,
Romain

[Updated on: Mon, 05 September 2016 14:55]

Report message to a moderator

Previous Topic:eIsSet prevents copying (setting) of attribute when default is set
Next Topic:Setting an Enum Reference Value in the Subclasses
Goto Forum:
  


Current Time: Fri Jun 25 11:37:09 GMT 2021

Powered by FUDForum. Page generated in 0.01426 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top