Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Update toE(fx)clipse 2.1 fails(Using native workbench update service to update to E(fx)clipse 2.1 fails.)
Update toE(fx)clipse 2.1 fails [message #1714094] Mon, 09 November 2015 20:36 Go to next message
Joe Van Steen is currently offline Joe Van SteenFriend
Messages: 25
Registered: March 2015
Junior Member
I had been using E(fx)clipse 2.0 under Luna. When I updated to Mars I continued to run 2.0 because E(fx)clipse 2.1 did not appear as a component I could update from the Mars libraries. (This was after 2.1 has been released.) Today I did a "Check for updates" and 2.1 appeared as an update . When I attempted the update from 2.0 to 2.1 I received the following error and could not complete the update:

Cannot complete the install because of a conflicting dependency.
  Software being installed: e(fx)clipse core Feature 2.1.0.201509020608 (org.eclipse.fx.core.feature.feature.group 2.1.0.201509020608)
  Software currently installed: Feature 2.0.0.201506111452 (org.eclipse.fx.core.shared.feature.feature.group 2.0.0.201506111452)
  Only one of the following can be installed at once: 
    Fake bundle for Javafx 2.2.0.201506111452 (org.eclipse.fx.javafx 2.2.0.201506111452)
    Fake bundle for Javafx 2.2.0.201508240501 (org.eclipse.fx.javafx 2.2.0.201508240501)
  Cannot satisfy dependency:
    From: e(fx)clipse core Feature 2.1.0.201509020608 (org.eclipse.fx.core.feature.feature.group 2.1.0.201509020608)
    To: org.eclipse.fx.javafx [2.2.0.201508240501]
  Cannot satisfy dependency:
    From: Feature 2.0.0.201506111452 (org.eclipse.fx.core.shared.feature.feature.group 2.0.0.201506111452)
    To: org.eclipse.fx.javafx [2.2.0.201506111452]


Since E(fx)clipse was not previously being installed from the Mars release software site is there something I need to clean up before the install will work?

Also, I have both Mars and efxclipse P2 repos being referenced in my Tycho/Maven POM files. Do I need to keep the efxclipse repo references or can I drop those and just use the Mars repo?

Thanks for any help in resolving this.
Re: Update toE(fx)clipse 2.1 fails [message #1714108 is a reply to message #1714094] Mon, 09 November 2015 22:50 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6398
Registered: July 2009
Senior Member
On 09.11.15 21:36, Joe Van Steen wrote:
> I had been using E(fx)clipse 2.0 under Luna. When I updated to Mars I
> continued to run 2.0 because E(fx)clipse 2.1 did not appear as a
> component I could update from the Mars libraries. (This was after 2.1
> has been released.) Today I did a "Check for updates" and 2.1 appeared
> as an update . When I attempted the update from 2.0 to 2.1 I received
> the following error and could not complete the update:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: e(fx)clipse core Feature 2.1.0.201509020608
> (org.eclipse.fx.core.feature.feature.group 2.1.0.201509020608)
> Software currently installed: Feature 2.0.0.201506111452
> (org.eclipse.fx.core.shared.feature.feature.group 2.0.0.201506111452)
> Only one of the following can be installed at once: Fake bundle for
> Javafx 2.2.0.201506111452 (org.eclipse.fx.javafx 2.2.0.201506111452)
> Fake bundle for Javafx 2.2.0.201508240501 (org.eclipse.fx.javafx
> 2.2.0.201508240501)
> Cannot satisfy dependency:
> From: e(fx)clipse core Feature 2.1.0.201509020608
> (org.eclipse.fx.core.feature.feature.group 2.1.0.201509020608)
> To: org.eclipse.fx.javafx [2.2.0.201508240501]
> Cannot satisfy dependency:
> From: Feature 2.0.0.201506111452
> (org.eclipse.fx.core.shared.feature.feature.group 2.0.0.201506111452)
> To: org.eclipse.fx.javafx [2.2.0.201506111452]

Need to try that myself - sometimes p2 is doing strange things. What
might work for sure is to uninstall e(fx)clipse 2.0 and afterwards
install e(fx)clipse 2.1.0.

>
> Since E(fx)clipse was not previously being installed from the Mars
> release software site is there something I need to clean up before the
> install will work?
> Also, I have both Mars and efxclipse P2 repos being referenced in my
> Tycho/Maven POM files. Do I need to keep the efxclipse repo references
> or can I drop those and just use the Mars repo?

We only push the Tooling to the Mars-Repo. So *no* you still need to
point to the runtime p2 repo as well.

Tom
Re: Update toE(fx)clipse 2.1 fails [message #1714114 is a reply to message #1714108] Tue, 10 November 2015 00:33 Go to previous message
Joe Van Steen is currently offline Joe Van SteenFriend
Messages: 25
Registered: March 2015
Junior Member
I did the uninstall 2.0 then install 2.1 and I am now up and running on 2.1.

BTW, when I first tried to install 2.1 after the uninstall I was still having some issues about conflicts with older material and 2.1. I used the option to eliminate the old conflicting material to allow 2.1 to install. I mention this because maybe that was part of my original problem above, not necessarily something in your packaging.

Thank you for your help.
Previous Topic:Breaking changes for Code-Editor in nightlies!
Next Topic:Drag and Drop to reorder Parts does not work
Goto Forum:
  


Current Time: Fri Jun 22 13:33:26 GMT 2018

Powered by FUDForum. Page generated in 0.02113 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top