Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Eclipse RCP with Sirius
Eclipse RCP with Sirius [message #1712903] Thu, 29 October 2015 09:19 Go to next message
Franck MIMET is currently offline Franck MIMETFriend
Messages: 28
Registered: August 2014
Junior Member
Hi everyboby,

I was developping an feature based application with an ecore model and Sirius for the graphical part.
When I tried to export it as a product, the dependencies imply that the same plugins have to be included with two different versions.
It works well as an application (I include the two versions in the target definition), but don't when I am creating the product, before exporting.

The plugins are:
org.apache.batik.css 1.6.0.v201011041432 / 1.7.0.v201011041433
org.apache.batik.util 1.6.0.v201011041432 / 1.7.0.v201011041433
org.apache.batik.util.gui 1.6.0.v201011041432 / 1.7.0.v200903091627

which are needed by Sirius 2.0.6 [1.6.0, 1.7.0]
and org.eclipse.e4.ui.css.core [1.7.0, 1.8.0]

I am using Eclipse Luna.

I am looking for a workaround for this issue.

Thanks
Re: Eclipse RCP with Sirius [message #1712942 is a reply to message #1712903] Thu, 29 October 2015 13:40 Go to previous messageGo to next message
Laurent Redor is currently offline Laurent RedorFriend
Messages: 267
Registered: July 2009
Senior Member
Le 29/10/2015 10:19, Franck MIMET a écrit :
> Hi everyboby,
>

Hi,


> I was developping an feature based application with an ecore model and
> Sirius for the graphical part.
> When I tried to export it as a product, the dependencies imply that the
> same plugins have to be included with two different versions.
> It works well as an application (I include the two versions in the
> target definition), but don't when I am creating the product, before
> exporting.
>
> The plugins are:
> org.apache.batik.css 1.6.0.v201011041432 / 1.7.0.v201011041433
> org.apache.batik.util 1.6.0.v201011041432 / 1.7.0.v201011041433
> org.apache.batik.util.gui 1.6.0.v201011041432 / 1.7.0.v200903091627
>
> which are needed by Sirius 2.0.6 [1.6.0, 1.7.0]
> and org.eclipse.e4.ui.css.core [1.7.0, 1.8.0]
>
> I am using Eclipse Luna.
>
> I am looking for a workaround for this issue.
>
> Thanks

At Obeo, we build a product, Obeo Desiger Community Edition [1], based
on Sirius and we have not this problem. The final product has both versions.
So, it's difficult to help you.

Best regards,

[1] http://www.obeodesigner.com/download

--
Laurent Redor - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius


Laurent Redor - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Eclipse RCP with Sirius [message #1712951 is a reply to message #1712942] Thu, 29 October 2015 14:28 Go to previous message
Franck MIMET is currently offline Franck MIMETFriend
Messages: 28
Registered: August 2014
Junior Member
I understand that my question was borderline.

In fact, it looks like bug #367187 "[patch] Product validation doesn't find plugin needed in two versions", which was closed in Eclipse Mars, so I think I need to patch my own Eclipse Luna Confused
Previous Topic:Label Expression :: "Unknown EMF Problem"
Next Topic:How to add icons to Table rows
Goto Forum:
  


Current Time: Mon Jan 25 02:28:08 GMT 2021

Powered by FUDForum. Page generated in 0.02099 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top