Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » [CSS] Problems with SVG-symbols for behavior elements in class diagrams
[CSS] Problems with SVG-symbols for behavior elements in class diagrams [message #1712109] Wed, 21 October 2015 10:56 Go to next message
Thomas Wiman is currently offline Thomas WimanFriend
Messages: 44
Registered: June 2012
Location: Stockholm , Sweden
Member

I am using Papyrus 1.1.2.
I am trying to use my own SVG-symbols defined in a CSS-stylesheet on Use Cases and Collaborations. When using Use-Case diagrams, my SVG symbols looks fine and the element names are displayed beneath the symbols.

But when using the same CSS-stylesheet on a class-diagram the SVG-symbols for Use Cases and Collaborations are presented within a thin frame (same frame as for unstereotyped elements) and the element name is hidden.
However, my SVG-symbols for Classes, Interfaces and Components works fine in the class diagrams.

Is there some limitations on the display of SVG-symbols for use cases and collaborations in class diagrams or are there any special CSS-constructions needed for displaying SVG-symbols for those kind of classifiers in class diagrams?

Thanks
Thomas



Thomas Wiman
MetaModelAgent Product Manager
Re: [CSS] Problems with SVG-symbols for behavior elements in class diagrams [message #1712111 is a reply to message #1712109] Wed, 21 October 2015 11:11 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 920
Registered: February 2011
Senior Member
Hi Thomas,

ClassDIagram doesn't support UseCases and Collaboration, but supports generic NamedElements (Which actually includes UseCases and Collaborations, indirectly). My best guess is that this specific "NamedElement" concept doesn't support full customization.

That shouldn't be too complicated to fix (Provided that's the actual issue). We'll investigate on that

Regards,
Camille


Camille Letavernier
Re: [CSS] Problems with SVG-symbols for behavior elements in class diagrams [message #1712129 is a reply to message #1712111] Wed, 21 October 2015 12:45 Go to previous messageGo to next message
Thomas Wiman is currently offline Thomas WimanFriend
Messages: 44
Registered: June 2012
Location: Stockholm , Sweden
Member

Thanks Camille for a quick answer,

I know that normally you are not supposed to use class diagrams for those kind of classifiers that "belongs" to other diagrams.
But occasionally, depending on the modeling domain, you may want to use and show relationships (e.g. traceability) between heterogenuous classifiers and for that reason it would be needed to be able show a classifier with a customized symbol in the "wrong" type of diagram.



Thomas Wiman
MetaModelAgent Product Manager
Re: [CSS] Problems with SVG-symbols for behavior elements in class diagrams [message #1712140 is a reply to message #1712111] Wed, 21 October 2015 13:50 Go to previous message
Mickael ADAM is currently offline Mickael ADAMFriend
Messages: 31
Registered: February 2014
Member
Hi,

I have created a bug: http://eclip.se/480307
This shouln't be complex to fix, I already know how to fix it.

Mickaƫl.

[Updated on: Mon, 26 October 2015 07:56]

Report message to a moderator

Previous Topic:Errors when opening a Mars model in Luna
Next Topic:Proposal: Adding palette tool entries for "missing" classifiers
Goto Forum:
  


Current Time: Sun Feb 23 11:16:05 GMT 2020

Powered by FUDForum. Page generated in 0.03645 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top