Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Cannot generate Model after upgrading
Cannot generate Model after upgrading [message #1711814] Mon, 19 October 2015 21:27 Go to next message
Anders Forsell is currently offline Anders ForsellFriend
Messages: 127
Registered: July 2009
Senior Member
Hello,

After upgrading to a later EMF version I cannot generate my model anymore.
It was working with EMF 2.8.3 (Eclipse 3.9), but not with EMF 2.11.0 (Eclipse 4.5).

The error I get is a parse error and I have traced it to be due to my DataType where I use a complex type, namely:
Instance Type Name = java.lang.Class<? extends com.example.ProductComponent>

Should I file a bug report?
Is there a workaround or a better way to do this?

Thanks,
Anders

[Updated on: Mon, 19 October 2015 21:27]

Report message to a moderator

Re: Cannot generate Model after upgrading [message #1711843 is a reply to message #1711814] Tue, 20 October 2015 06:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30554
Registered: July 2009
Senior Member
Anders,

I tried a data type with java.lang.Class<? extends java.lang.Object> and
experimenting discovered that using it in a multi-valued attribute produces:

public EList<Class<? extends Object>> getXs() {
if (xs == null) {
xs = new EDataTypeUniqueEList<Class<? extends
Object>>(Class<? extends Object>.class, this, ExamplePackage.X__XS);
}
return xs;
}

I've opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=480178 and
committed the fix.


On 19/10/2015 11:27 PM, Anders Forsell wrote:
> Hello,
>
> After upgrading to a later EMF version I cannot generate my model
> anymore.
> It was working with EMF 2.8.3 (Eclipse 3.9), but not with EMF 2.11.0
> (Eclipse 4.5).
>
> The error I get is a parse error and I have traced it to be due to my
> DataType where I use a complex type, namely:
> Instance Type Name = java.lang.Class<? extends
> com.example.ProductComponent>
> Should a file a bug report?
> Is there a workaround or a better way to do this?
>
> Thanks,
> Anders
Re: Cannot generate Model after upgrading [message #1711844 is a reply to message #1711843] Tue, 20 October 2015 06:25 Go to previous message
Anders Forsell is currently offline Anders ForsellFriend
Messages: 127
Registered: July 2009
Senior Member
Thanks Ed,
I was indeed using the type in a multi-valued attribute.

Anders
Previous Topic:Auto-completion for EMF Item property
Next Topic: [XCore] xtend-maven-plugin used with tycho don't generate sources on JENKINS
Goto Forum:
  


Current Time: Tue Oct 22 09:36:43 GMT 2019

Powered by FUDForum. Page generated in 0.02071 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top