Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMF Forms] 1.7.1: target definition broken?
[EMF Forms] 1.7.1: target definition broken? [message #1711589] Sat, 17 October 2015 20:00 Go to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
Hi

I tried to make a target definition from http://download.eclipse.org/ecp/releases/releases_target_17/

it fails because it's missing ECP Change Broker 1.7.0
Re: [EMF Forms] 1.7.1: target definition [message #1711590 is a reply to message #1711589] Sat, 17 October 2015 20:09 Go to previous messageGo to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
I was wrong, Change Broker is there

but what features exactly should be selected to get EMF Forms running?
will be required ECP bundles installed when all EMF Forms bundles are installed?

And what is else to do after setting target platform in eclipse?
If I do RCP product export, does it then contain all the needed bundles?

Why the separation between target platform bundles and not-target-platform bundles?
Re: [EMF Forms] 1.7.1: target definition [message #1711592 is a reply to message #1711590] Sat, 17 October 2015 20:25 Go to previous messageGo to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
what is exactly to do with http://download.eclipse.org/ecp/releases/releases_target_17? what is it good for? is it for getting all the bundles that are missing in the IDE? are they into IDE after setting target platform but somehow different?
Re: [EMF Forms] 1.7.1: target definition broken? [message #1711605 is a reply to message #1711589] Sun, 18 October 2015 09:00 Go to previous messageGo to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
I tried many times to make target definition from the URL (have selected all to go sure) but it fails every time because it's missing dependencies. Those missing deps are every time different, but in most cases they come from 1.7.0

[Updated on: Sun, 18 October 2015 09:02]

Report message to a moderator

Re: [EMF Forms] 1.7.1: target definition broken? [message #1711731 is a reply to message #1711605] Mon, 19 October 2015 13:04 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

if the result is different everytime, I assume you might have some
connection issues? Maybe a proxy or a virus scanner?
If you have a reproducable error, please share it.

Best regards

Jonas

Am 18.10.2015 um 11:00 schrieb Klim Tow:
> I tried many times to make target definition fro the URL but it fails
> every time because it's missing dependencies. Those missing deps are
> every time different, but in most cases they come from 1.7.0


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Re: [EMF Forms] 1.7.1: target definition [message #1711733 is a reply to message #1711592] Mon, 19 October 2015 13:06 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
We maintain two update sites, one containing bundles, which can be
installed into the IDE and one which also contains stuff, which should
only be in your target platform, but also everything else. So for
defining a target platform, the target plaform update site is the right
one...


Am 17.10.2015 um 22:25 schrieb Klim Tow:
> what is exactly to do with
> http://download.eclipse.org/ecp/releases/releases_target_17? what is it
> good for? is it for getting all the bundles that are missing in the IDE?
> are they into IDE after setting target platform but somehow different?


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Re: [EMF Forms] 1.7.1: target definition [message #1711753 is a reply to message #1711733] Mon, 19 October 2015 14:01 Go to previous messageGo to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
Hi Jonas

why should the stuff from the target platform not be installed into IDE? Will it break IDE?

I don't think there is a problem with connections... however, I am able to reproduce same error message a couple of times

index.php/fa/23612/0/
Re: [EMF Forms] 1.7.1: target definition [message #1711754 is a reply to message #1711753] Mon, 19 October 2015 14:04 Go to previous messageGo to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
And this is what I did:

1. create new target def file
2. insert the URL
3. select all
Re: [EMF Forms] 1.7.1: target definition [message #1711830 is a reply to message #1711754] Tue, 20 October 2015 05:26 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
You will need other stuff that your application depends on, too. Best
woudl be if you add the Mars update site.

Am 19.10.2015 um 16:04 schrieb Klim Tow:
> And this is what I did:
>
> 1. create new target def file
> 2. insert the URL
> 3. select all


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Re: [EMF Forms] 1.7.1: target definition [message #1711915 is a reply to message #1711830] Tue, 20 October 2015 09:55 Go to previous messageGo to next message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
I had also target definition based on the current platform + EMF Forms target platform and it did not do

Now, I tried Mars update site + EMF Forms target platform - Mars update site missed dependencies to EMF... so I added EMF update site and it's missing some deps as well

index.php/fa/23627/0/

I think I am doing it somehow wrong. Could you post or upload your target platform definition file here?
Re: [EMF Forms] 1.7.1: target definition [message #1712019 is a reply to message #1711915] Tue, 20 October 2015 18:32 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

I am sorry, but it is pretty hard to solve your target platform issues
without really looking at it.
Here you find the ECP target:
https://git.eclipse.org/c/emfclient/org.eclipse.emf.ecp.core.git/tree/releng/org.eclipse.emf.ecp.target.rcp.mars/ecpMars.target?h=develop

You need to add EMF Forms to this target, though.

Best regards

Jonas

Am 20.10.2015 um 11:55 schrieb Klim Tow:
> I had also target definition based on the current platform + EMF Forms target platform and it did not do
>
> Now, I tried Mars update site + EMF Forms target platform - Mars update site missed dependencies to EMF... so I added EMF update site and it's missing some deps as well
>
>
>
> I think I am doing it somehow wrong. Could you post or upload your target platform definition file here?
>


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Re: [EMF Forms] 1.7.1: target definition [message #1712032 is a reply to message #1712019] Tue, 20 October 2015 23:35 Go to previous message
Klim Tow is currently offline Klim TowFriend
Messages: 49
Registered: September 2015
Member
thanks

http://download.eclipse.org/eclipse/updates/4.5 was wrong

with http://download.eclipse.org/releases/mars it does
Previous Topic:[EMF Forms] validation processing
Next Topic:[EEF] Usage of view reference
Goto Forum:
  


Current Time: Tue Feb 18 10:08:12 GMT 2020

Powered by FUDForum. Page generated in 0.03480 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top