Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP in combination with QVT (com.ibm.icu issue)
RAP in combination with QVT (com.ibm.icu issue) [message #1710560] Wed, 07 October 2015 14:23
Karel Gardas is currently offline Karel GardasFriend
Messages: 33
Registered: July 2009
Member
Hello,

I'm trying to put together application which is using QVT and change its UI to RAP. The problem is that RAP plugins depends on com.ibm.icu.base and QVT (org.eclipse.m2m.qvt.oml) depends on com.ibm.icu since it requires com.ibm.icu.lang package.
This should not be issue as long as com.ibm.icu provides all packages of com.ibm.icu.base which seems to be the case, the problem is that somehow RAP is not compatible with it (com.ibm.icu) and complains about missing text subpackage:

org.osgi.framework.BundleException: Could not resolve module: com.objectsecurity.openpmf.rap.ui.component_editor [9]
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.rap.views
-> Bundle-SymbolicName: org.eclipse.emf.parsley.rap.views; bundle-version="0.5.0.v20150910-1546"
org.eclipse.emf.parsley.rap.views [70]
Unresolved requirement: Require-Bundle: org.eclipse.emf.parsley.views.common; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.emf.parsley.views.common; bundle-version="0.5.0.v20150910-1546"
org.eclipse.emf.parsley.views.common [18]
Unresolved requirement: Import-Package: org.eclipse.emf.common.ui
-> Export-Package: org.eclipse.emf.common.ui; bundle-symbolic-name="org.eclipse.emf.rap.common.ui"; bundle-version="2.8.0.v20140901-1055"; version="0.0.0"
org.eclipse.emf.rap.common.ui [29]
Unresolved requirement: Require-Bundle: org.eclipse.rap.ui; bundle-version="[2.3.0,3.0.0)"
-> Bundle-SymbolicName: org.eclipse.rap.ui; bundle-version="2.3.2.20150119-1706"; singleton:="true"
org.eclipse.rap.ui [45]
Unresolved requirement: Require-Bundle: org.eclipse.rap.ui.workbench; bundle-version="[2.3.0,3.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.rap.ui.workbench; bundle-version="2.3.2.20150119-1706"; singleton:="true"
org.eclipse.rap.ui.workbench [61]
Unresolved requirement: Import-Package: com.ibm.icu.text


The problem is that text subpackage is well exported by com.ibm.icu bundle (at least as far as I understand its manifest)

Do you have any idea how to solve this issue?

Thanks!
Karel
Previous Topic:Keycode for delete and backspace
Next Topic:How to debug RAP Client Errors
Goto Forum:
  


Current Time: Fri Aug 23 08:43:20 GMT 2019

Powered by FUDForum. Page generated in 0.02323 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top