Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » PHP extensions not being loaded in Mars
PHP extensions not being loaded in Mars [message #1709366] Mon, 28 September 2015 03:53 Go to next message
Patrick Stuart is currently offline Patrick StuartFriend
Messages: 10
Registered: January 2015
Junior Member
System information:

  • Ubuntu x86_64 14.04
  • Eclipse 4.5 Mars 64
  • Java version "1.7.0_79"; OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-0ubuntu1.14.04.1)
  • PHP version 5.5.9
  • XDebug
  • Eclipse PDT 3.5


Hello. I recently upgraded from Luna to Mars. However, I'm now getting a PHP dependency error when I try to execute code directly from Eclipse. I do not get this error when I run code directly from the command line.

I can confirm I am using the correct php.ini file, and the temporary php.ini file created by Eclipse is an exact copy of the original.

Here is the error message:

Fatal error: Uncaught exception 'DependencyError' with message 'Missing dependency: \`cURL\`. Download from <http://us2.php.net/manual/en/curl.requirements.php>' in [STRIPPED] on line 82


Any help would be appreciated. Thank you!


Re: PHP extensions not being loaded in Mars [message #1709401 is a reply to message #1709366] Mon, 28 September 2015 09:16 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 249
Registered: March 2013
Senior Member
Can you check "Use system default php.ini configuration" in php executables and try again?

Re: PHP extensions not being loaded in Mars [message #1710072 is a reply to message #1709401] Sat, 03 October 2015 18:05 Go to previous messageGo to next message
Patrick Stuart is currently offline Patrick StuartFriend
Messages: 10
Registered: January 2015
Junior Member
Dawid Pakula wrote on Mon, 28 September 2015 09:16
Can you check "Use system default php.ini configuration" in php executables and try again?
Oops, that fixed it. How embarrassing! I guess I missed it because the checkbox is invisible on my installation.

Thanks.

[Updated on: Sat, 03 October 2015 18:06]

Report message to a moderator

Re: PHP extensions not being loaded in Mars [message #1710073 is a reply to message #1710072] Sat, 03 October 2015 18:16 Go to previous message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 249
Registered: March 2013
Senior Member
Can you attach screenshot?

Or better just prepare a bug: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=PDT

BTW: Yesterday eclipse released new version, maybe this will UI problem.

Edit: I see environment info in first post


[Updated on: Sat, 03 October 2015 18:17]

Report message to a moderator

Previous Topic:Can't exec "gdb": No such file or directory
Next Topic:Configuring PDT to mark undefined methods & functions
Goto Forum:
  


Current Time: Wed Oct 17 04:48:45 GMT 2018

Powered by FUDForum. Page generated in 0.02836 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top